WD Smart Ware does not see/recognise WD MyCloud


have a problem - WD Smart Ware does not see/recognise WD MyCloud. 

Have it since Dec '13. Initially worked ok, took 20 something hrs to backup my data. I noted that after I hibernated my laptop, WD Smart Drive stopped seeing WD My Cloud. I could still see WD My Cloud from Windows (Win 8, I can copy files via Windows no problem), but WD Smart Drive didn’t see it (only Dropbox was visible). I checked a few sample files - it seems backup was being done even though WD Smart Drive software didn’t see My Cloud. Restarting helped for a while, but after hibernation problem reocurred. After 3 mth it stopped working. I tried connecting MyCloud with ethernet cable directly to the laptop, didn’t help. Few days ago, I uninstalled WD Smart Ware, downloaded the most recent one from WD website and installed. Backed up whole data again, 20 sth hours, worked fine for a day, but when I hibernated my laptop, WD Smart Ware doesn’t see WD MyCloud. Restart of the laptop hepled, but it is not a solution, it will drop again as it did many times. 

Any ideas how to fix it?

Of interest - WD Quick View doesn’t work. It installs all right, but doesn’t launch. Press the icon - nothing happens, WD Quick View doesn’t start. 


Hello, try setting a static IP for the My Cloud. 

How to configure a WD My Cloud or WD My Cloud EX4 Personal Cloud drive with a Static IP 


just switched MyCloud to static IP. Didn’t experience any interruption. WD Smartware sees WD MyCloud for now. Windows Exlorer sees WD MyCloud as well. 

Will monitor over the next few days to check if WD MyCloud does not dissapear in WD Smartware.

Hi, checked it further. WD MyCloud drive has now static IP. However, when I folded my laptop’s screen for the night and it hibernated (or whatever it does), the next day WD MyCloud was not visible in WD Smartware. It probably does the backup though, as I can see in task manager the WD SmartWare and WD Backup Engine running. 

Any ideas how to fix it - so that WD Smartware doesn’t drop WD MyCloud after laptop has been hibernated/closed?