WD ShareSpace with Fedora 13


#1

Hi all - 

I’ve been tasked with accessing data stored on a WD ShareSpace drive using a computer with Fedora 13 installed.  I’m vaguely familiar with Linux but have no experience with networking in a Linux environment.  How can I connect to this drive and access the stored data?


#2

On the Fedora desktop, go to “Places->Network” If you don’t see the Windows network Icon visible when the window opens, got to “File->Connect to Server” on the  window you’ve opened. There is a drop down menu for Service type. Select “Windows share” and go from there.

HTH

–dennis


#3

Thanks for the help dennis.  When I tried to connect using the Windows Network icon I got an error message “Unable to mount location.  Failed to retrieve share list from server.” 

I then tried the second suggestion listed, to connect to server and selecting “Windows Share” from the drop-down menu.  I am then asked for the server name, with optional entries for Share, Folder, User Name, and Domain Name.  I don’t know what to enter here.  IP address, name of ShareSpace drive?  I’m going to look into it, but whatever it wants, I am not sure I have anything like an IP address or a name assigned to the drive - is there a way I can find it?  Thanks again!


#4

The Share name is either the DNS entry or the IP Address (the DNS entry wil only work if DNS works on your net, otherwise enter the IP Address.

The Folder is the name of the Sharespace folder you want to access such as “Public.”

The Domain is the windows domain you belong to. I think it defaults to MyGroup, but the windows default is usually “Workgroup.”

Then, of course, you need an account on the sharespace so usr name and pwd.

HTH,

–dennis


#5

Looking back at my reply I realize I should have been more specific.  I don’t know what to put for the server name either.

And as far as the IP address of the ShareSpace…I don’t know what that is.  Any way I can find it?


#6

Just ask your admin for all that data in the menu. I’m assuming someone else administers that device and the network.


#7

Actually, the computer and drive are not on a network.  I have been given the computer, the ShareSpace, and a vote of confidence and told to access the data on the ShareSpace.  So I have the computer connected to the ShareSpace with a CAT5 and no other connections.


#8

from fedora do “arp -a”. You should see the IP address IF one is assigned.

However, you have to somehow have an address assigned to the device either through DHCP (you can use your system for that) or you have to login through the admin account. Both your Fedora machine must be on the same network with different IP addresses.

Connecting a network cable between 2 machines doesn’t guarantee they can talk to each other. The must be on the same network.  That has specific meaning in the IP world. If you are not well-versed in the details of IP networking, you need to find someone who is.

You could connect both machines to a small router that is a DHCP server as long as your machine and the sharespace are also  DHCP clients. Then they will talk to each other. Also, connecting just a networking cable between machines requires it be a cross-over cable, not straight-thru.


#9

Tried arp -a … nothing.

So does that mean that an IP address is not assigned to either my computer or my drive?  How would I use DHCP to assign IP addresses?

When you talk about being on the same network, I know that they need the same subnet mask(?) and in Windows networking they need to belong to the same workgroup.  If there’s more, and how to do it in Fedora, I don’t know.


#10

arp shows other computers on the same net that you can see, not yours. In Linux it’s ifconfig -a to see your macjine’s IP address.

Go get a linksys router or any other home networking router and connect both to that router. If DHCP is enabled, they will each get an IP address and you can talk to the sharespace.

The default setup in Linux (and sharespace which runs Linux) is to do DHCP, and the router will act as the server.

then arp -a will work


#11

In Nautilus go to the address bar (press CTRL + L if you don’t see it).

Type smb:///

and press ENTER. Does that give you anything or does it time out?


#12

Trying smb:/// in Nautilus, I get

Could not display “smb:///”.

Error:  Failed to retrieve share list from server

Please select another viewer and try again.

This comes up immediately after I hit Enter.


#13

I’ve done a little more snooping around and it looks like DHCP is not enabled, nor is the network card active.  As far as I can tell I need administrator privileges to rectify that, which I do not yet have.  But should later today…


#14

rcrummett wrote:

I’ve done a little more snooping around and it looks like DHCP is not enabled, nor is the network card active.  As far as I can tell I need administrator privileges to rectify that, which I do not yet have.  But should later today…

The error you got with the smb:// command in nautilus suggests that you have some fundamental network issues to sort out first, as your post suggests.

regards…


#15

Okay…

Got the root password and enabled the network card.  Still seeing the same errors.  Running ifconfig I see that my network card has been assigned an IPv6 address.  Nothing for the drive, though.

Tried the suggestions given previously (Windows Network, smb:///) and still see same results. 


#16

smb:// will never work until both devices have a proper IP4 address. because the sharespace is not accessible until it has one, you need to provide it one and that means having a DHCP server around to “boot strap” it. Get a router, plug both machines into it and then they will both have an address. Assumed your fedora system has the client enabled to request an address via DHCP.  If not there is an admin interface on the fedora menu. It’s under system->administration from the fedora desktop.

Directly connecting two machines together without a switch or router inbetween requires a special cross-over cable. Even then the sharespace will still want a DHCP server to obtain its address and  as well your fedora system.  Save yourself more headaches and just do it the way I described above.


#17

Help me understand something, then:

The data that is on this drive was put on the drive using a Windows XP machine.  The Sharespace was connected directly to the computer using a straight-thru network cable.

Why wouldn’t I be able to use the same configuration in Linux, by simply connecting a network cable between the computer and the Sharespace?  I’m not trying to be stubborn, I really am curious why this may be.

I’ve done some more looking on the computer and it doesn’t appear to have DHCP installed.  However it is not connected to the Internet so I can’t just download from a repository and install.  Sigh…


#18

point 1. I find it hard to believe that they were connected via a straight-thru cable. The transmit and receive wires have to be crossed.  A switch or router does this for you. The only exception is if the ports are cable of doing this on their own. It’s called auto-switching or polarity-switching. Common on switches/routers.  Nevertheless,  you need someway to assign IP addresses and this doesn’t happen on it’s own.  Whomever did the XP setup may have also made the XP machine a DHCP server, in which case it will work as the XP machine will be both a client and server.

You can also do this with the Fedora machine if the DHCP server software is installed. The client software for DHCP is usually automatically installed during Fedora installation, so it’s there and the default method is to do a DHCP request.

I was a networking specialist for 30+ years, so you really have to trust me on this… ;).


#19

I’m certainly not questioning your background or experience, or anything like that.  You know more about this type of thing than I and have pointed me in a direction that I feel like I am able to ask some more advanced questions instead of “it doesn’t work”.

Maybe it’s time for the whole story.  I know that the ShareSpace was connected to an XP machine with a straight-thru cable because I am the one that connected it.  I stored some data on the ShareSpace using XP, no problem.  Connect the cable between the computer and the drive, run the software…problem solved.  That computer is no longer available for my use, in case you wonder why I’m not using it anymore.  And I didn’t share this beforehand because I didn’t think it was relevant.  My apologies if that was not the case.

I’ve got a different workaround planned that should hopefully work (use a Windows PC to access the ShareSpace and transfer all the data to a USB drive).  Thanks for all the help.  I wish I could have had success with this, but if nothing else I have learned a lot and I am appreciative of that.