WD Red 5tb NAS Drive that diags say is fine but has an odd failure

I have three of these drives installed in my system with a 500 GB WD boot drive. There is an assortment of other external drives that don’t seem to affect the issue.
I installed all three drives while running Windows 7. While copying files to the one 5 TG drive, the copy process would get to about 75% and the slow down to a crawl, let it run for about an hour which allowed it to complete only 2% more in the copying process. I decided it might be a corrupt file of something else on the drive. The files copied to the other drives flawlessly with no reduction in speed. Decided to remove and reset the partition, drive showed up as fine in disk management, removed and reset partition. Tried to format and windows could not complete, no reason presented. I downloaded all the pertinent software from WD which again showed the drive to be fine and still could not format. Left it alone for a couple of months, trying format every once in awhile with no success. Upgraded to Windows 10 but that did not help this drive at all. Swapped it out for a couple other drives I have but appears windows 10 did not like that at all. Placed it back in the system and made one more attempt. Wow, it formatted but back to the same issue I had in the beginning, copy any size or type of file, gets to about 75% and stalls. Think this thing needs replacement? Note: I received these three drives as comp for the number of wd failures in the past 3 to 5 years, thinking I have another run around coming

Hello,

What software are you using to test the drive? If is the WD DLG Tool, make sure to run the extended test.

I ran the test again on all three of my 5TB drives, all came back with the same result:

Test Option: EXTENDED TEST
Model Number: WDC WD50EFRX-68MYMN1
Unit Serial Number: [[DELETED-Privacy]]
Firmware Number: 82.00A82
Capacity: 5000.98 GB
SMART Status: PASS
Test Result: PASS
Test Time: 08:18:15, August 25, 2016

But this is the one with the issue