WD Red 4tb Drive Formatting with no progress

So just received this brand new drive. Initially it would show up in drive management but would hit an error anytime I tried to initialized the drive. I swapped out the SATA cables and the drive showed up. So next I ran quick format which also came back with an error.

I finally hit full format for half the drive (2tb of the 4) and now I’ve been waiting for 20 hours with no progress displayed for the format. Wondering how long is ‘too long’ to wait for this process? Thanks!

Hi dr.weird,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

Issue was resolved. Apparently the 20+ hour format was simply stuck and doing nothing. I cancelled and once again changed the sata cable along with the sata port on my motherboard, and it fired up like it should’ve in the first place. Quick format was complete in seconds and the drive is now working properly.

The I/O error I recieved repeatedly must’ve been from a fault SATA port/cable.