WD Play "sub-titles off"

When movie begins, “sub-titles off” is listed in the upper left corner. How do I remedy this? Sorry for what is probably a really simple question but I’m semi-computer illiterate.

Thanks in advance

When playing from the network, I’d like to know that too :slight_smile:

Subtitles seem to work only when playing from USB

Press Options on remote, then subtitle.

Or Setup / Video settings / subtitle default / on

They should play automatically if you’re playing from USB. You can en/disable them as richUK said but they should start with the movie. I have tested so far .SRT and embedded MKV subtitles, these do work, but again, when playing from USB.

Also important is to have the exact same name for the subtitle and the movie

Example (correct):



Example (incorrect):



Subtitles need to be muxed with movie file so you could have them over network.

Download  http://www.bunkus.org/videotools/mkvtoolnix/

and use mkvmerge gui to mux them into single file.