WD Photo problem?

My iphone updated the WD Photo app yesterday.  It was working perfectly. With this new version 2.0.0 I get “No Photo’s found”.

I cleared the cache on the app, deleted the pairing on the hub.  Then added the hub again via the app.  It does’nt ask for a code in version 2, just goes straight into “first time setup”, then immediately tells me “no photos found”.  The hub however does recognise that an iphone has been attached?

Has version 2 removed the need to enter any form of key?  Has anyone actually got it working?

I’ve just rebuilt the media library on my hub to no avail, and then started a rebuild on the twonly database.  Does anyone know whether WD Photos used the library or twonky?

everything is rebuilt now, Still displays No photo’s found when using the iphone app. Checked the twonky server is pointing to the right folder, it is, and you can browse and look at photo’s via the twonky web interface just fine.

We use the app a lot, most frustrating.

Well, for one thing, Twonky has absolutely nothing to do with WD Photos.  You can even disable Twonky and WD Photos still works.

And yes, 2.0 removes the needs for access codes as long as you’re on your local network when you do the pairing.

If you’re NOT on the local network, you can still use codes.

I haven’t tried 2.0 on the Hub yet, because I usually use a MyBook Live. 

Has anyone got Version 2 of WD photo’s to work yet or is it confirmed as knackered?

I have downloaded the iPhone app update recently on my iPhone 3GS with iOS5.1 but i haven’t tested it yet with my Live Hub. I will let you know as soon as i did. It worked perfectly with previous version to download and upload photos and videos.

You could try here


I fixed it eventually, you have to turn mobile off, then on again, it seems to rebuild the file database, and it all works again.