WD Photo does not refresh its folder contents

Hi all,

I use WD Photo on my Android phone to backup my photos, the phone’s camera photos are backed up fine as I can see them if I access my MyCloud device from my laptop (although I get duplicated copies of same photo sometimes, but that’s a different issue), however, on the WD Photo app, when browsing through my MyCloud device, the content are always outdated, like majorly outdated. I’ll give you an example which is happening right now on my WD Photo app. We’re going into October now and I’ve taken hundreds of photo on my phone for the past few months (Can see them backed up by accessing MyCloud via laptop, etc), but when I open the WD Photo app, the latest photos are in June! So it is almost 4 months outdated. There is no refresh button that I can use to manually refresh like a normal user would expect, I tried to clear cache but it still shows the same photos and folders.

So my question is:

  1. Anyone having the same issue?
  2. Any ideas on how to force a refresh/sync?
  3. Can WD developers add a simple “Refresh” option in the WD Photo app?

Hi, the last time that WD Photos was updated was on February 27 2015 and some features might be a little buggy. Have you tried uninstalling and re-installing the app?

Have you opened up the Photo app and using the icons at the top, opened the Folder View. Mine for Sept. just went from two to 46 photos.

I’ve tried switching between views but nothing was updated, still not seeing my latest backed up photos…

I think I will try the other app - WD My Cloud instead since that app is more up-to-date. The only worry I have is that this new app will not “continue” backing up my photo, but instead start a new share to back up my photos again and I will get duplicates, etc.