WD Passport ? WTF?


#1

Hello all

I have a small problem

I bought a WD PASSPORT PRO and I can not make it work as Network Drive (uploadind/dowloading via WiFi)
Everything works fine as long as I’m connected to WD Network (defalut network name "My Passport (5 GHz) )
I can access ineternet, and files on my WD.
After connecting to my Home Network (not WD Network) i cannot access files on my WD.
WD disk is connected to my home network via WiFi

Is it possible to make the disk visible to every computer connectet to home network
I’ve been struggling with it for several days

I using Windows 10 :frowning:

PS: Sory for bad english


#2

Ah, this is a relatively easy one.

You need to go to the network page and click on the network your are connected to. There are two options there, one of which is called “Share content on this network”. You need to check that box.

With it checked, you can access the drive like any other network hard drive. (it will just be slow. . .since it is a wireless, not a wired, connection). Very convenient when at home.

With the box “unchecked”, you won’t be able to access the drive contents from the network side. You would want to have this unchecked if you were to be accessing from a public network where you don’t want others accessing your drive.

Two more tips:

  1. Never “map” the drive to a drive letter (makes it harder for a ransomware attack affecting the drive) on any of your machines.
  2. I like assigning a static IP address, makes it easier to access the drive by typing the ip address in address bars.

#3

Fyi I can access mine on home network via File Explorer in the Network section of FE screen.


#4

I have several machines on my network. . . .file explorer “sees” the NAS about 1/2 the time.

Usually, I just type the drive name in the address bar (\Name). . .and it comes right up just as if I typed a drive letter. Recently, I have saved the NAS as a “quick link” in the “quick access” section (Win10) (left click on “Quick access”, select “Pin Current Folder”)


#5

Next time you don’t see the nas when you should, hit the windows refresh icon of file explorer screen and you will likely see nas listed again.


#6

Mike;

That is good advice. Which doesn’t work. :slight_smile:

Maybe I have a setting wrong somewhere.** Maybe my router is flakey. But the bottom line is “Network” doesn’t always show all the network computers correctly. A refresh has equal probability of making something disappear as appear.

The WD stuff does consistently appear as “storage”, and “media devices”, but as “computers” so that I can “easily” access the file system. . . nope.

However, when I address the computer/drive/server in the address bar (either by IP address or by computer name). . it always works. And it’s easy. So I am not bothered by it.

** Ok. . .I have been playing with this yet again. Not much joy - - -> I get seem to get Win10 machines to see each other by changing settings on the “Function Discovery Resource Publication service” and it’s cousin, Function Discovery Provider. And of course, SMB1.0 *** must be enabled. The WD drives (the passports and the NAS) are not running windows. . … so I have no idea what I have to jiggle to make those guys show up consistently.

*** From a security viewpoint, SMB1.0 Client must be enabled (to get this all to work) SMB1.0 Server should be off.


#7

Well, the screen refresh works on my Win 7 and 10 every time/
I always look for NAS in left pane not the cluttered right pane of FE.


#8

Mike; Did some more playing. Today I discovered that the “workgroup” name was not consistent for all the devices on the network. Some were on “workgroup” and some were on “OtherGroup”. Now I have switched everything to “workgroup”, and all seems well.

No, I was not getting consistent behavior within the two groups. I suspect that something just wasn’t working correctly when you have two workgroups operating on the same network. I know MS is getting away from using workgroups . .probably for good reason.


#9

Good discovery. Years ago I had a device that was not setup with workgroup as the default. Fixed it and life has been good. It was an older PC; Microsoft was not consistent using WORKGROUP as default name back then.