WD Passport Unable to Create Time Machine Back Ups on Mac OS Mojave

Hey support forum,

So I have had a working Passport 1TB (latest model) recently purchased and would occasionally make backups on my computer while on High Sierra and now am having an issue with Mojave. After updating, I have had the issue where my computer recognizes the external hard drive and displays it on the desktop and in finder, but once I begin to create Time Machine backups, then the device looks like it’s processing information - but my 2013 MacBook Air doesn’t register it doing anything and says “preparing backup”. I have tried updating the software on the hard drive after this and all of the programs usually revert to crashing since updating to Mojave.

Is there any additional drivers or updates that I need to make my Passport compatible with my MacBook? Or is my hard drive damaged?

Side note (In Chronological Order): My MacBook worked on High Sierra (Made Backups through TimeMachine - Updated to Mac OS Mojave (Never made any backups) - Moved locations to a new house (Could have been damaged somehow? Made sure to keep it close so it wasn’t damaged) - Now unable to make any backups on Mojave.

So either the Passport needs to be updated / install additional software to allow compatibility / Accidental minor damage.

Hello joeonthedownlow,

You should test the drive using WD Drive Utilities or try to re-configure the Time Machine Backup again on the drive after removing the existing backup drive from Time Machine Preferences.

To configure the Time Machine, you can refer the link given below.

https://support-en.wd.com/app/answers/detail/a_id/18952