Wd passport ticking in windows 7?


I have around 3-4 years old WDBAAA3200ABK  Passport hard drive. It was working fine with Windows XP and Vista, but after I installed  Windows 7 It doesn’t work properly - with same hardware…

after I plug It into USB port, hard drive starts TICKING !!  Sometimes It eventually opens in Windows, but It doen’t work properly (very slowly or nothing at all - with ticking all the time).

since I know that TICKING isn’t  good as It may damage hard drive, what should I do to fix this ?? I’ve updated WD smartwave - nothing better, tried to download firmware for hard drive - couldn’t do it as hard drive won’t be recognized  or not working properly :frowning:

I’ve also tried hard drive on another PC with XP - working perfeclty !!

This is clearly a computer issue, perhaps the drive is not receiving enough power from the Windows 7 computer. Have you try replacing the USB cable or using a powered USB hub.

im having the same problem execept dat is happening on all the versions of windows after i plug it in it starts ticking ive tried changing the usb cable and also used a powered USB hub and nothing 

thanks for your advice Awopero,

I have tried with two different  USB cables and still everything same !!! … I have two USB slots which works perfectly with same cables on my android phone, digital camera and every USB sticks I have !!

I  noticed that when I plug my WD hard-drive into one USB slot drive starts ticking, and on the other USB slot nothing happens (not ticking, not recognizing) ?!?   I already mentioned that this hard drive worked perfectly on all previous Windows versions so I really don’t have clue what is going on !!

I also suspected that It has to do something with power supply to WD hard drive, so I am wondering if  It’s possible that  my power on USB slots is devided so It can’t produce enough power to spin the disk ??

I haven’t tried powered USB hub though, but I still think that cause of problems may be of software issues - maybe Windows 7 configuration  settings for USB ports are working differently than previous OS, maybe USB 2.0 drivers on my PC are corrupt  or maybe I have corrupted the drive (but then again, drive works perfectly on computers with XP )

Oh ,and my PC is not too old -  MSI MS 7528  PCI motherboard with Intel Dual core 2.5 Ghz - so power to each USB slot should be more than 500 mb/sec ?!?

If the drive is warranty contact and ask about a Power Booster cable. It usees 2 USB slots on PC and sometimes that works. An awful lot of PCs use barely adequet power supplies and these drives are very sensitive to voltage.


I guess everyone still thinks that power is the maine issue :frowning:

O.K., I’ll try to buy some powered USB hub, but I think that won’t solve It - I already told that this drive works perfectly on much slower, older computers with other Windows OS and It also worked fine on mine PC until I installed Windows 7 months ago…

Thanks for help !

Did you install Windows 7 with the drive connected? It has been known to cause problems.


I have checked hard-drive again and I noticed that i have Windows 7 OS on It, but I don’t remember if I installed Windows 7 with drive connected or from the  drive :frowning:

Is there some other way than reinstalling OS  if I did what you said, because I have certificats on my PC and may things whcih I can’t remove from It ?