WD Passport Studio doesn't mount to MacBook OS X 10.6.8

My WD Passport Studio is not mounted after OS update.

Disk Utility view WD passport but it’s not mounted. Tried connecting via FireEWire and also connect directly to both of the USB ports. Only used original fFireWire cable and original short USB cable.

  • The disk is visible in the left panel, the Mount icon is grayed out.
  • Tried  “Repair Disk Permissions”. No errors reported.
  • Tried “Repair Disk”. No errors reported.

The drive have data on it, I will not reformat it :frowning:

I have tried oeverything in this thread on Apple Support Community:


Setup for Finder:

Finder > Preferences and click on General, all these three boxes are checked:

  • Hard disks
  • External disks
  • CDs, DVDs and iPods

Also tried to download WD Macintosh + TURBO drivers and WD Drive manager (mac) from here:


WD Drive Manager detects “My passport USB”, but “used space” is greyed out.

No help in installing the +TURBO drive… No positive result.

Please help?

You can try to recover the data with a Data Recovery software, then you can format the Drive.

Where do i find the software?


Just go to Google :wink:

Hmmm, I’m not after buying any software like “Data Recovery sofware” - what i want is for WD to help me find a solution to how to mount my HD!

I’ve seen several treads on the same issue, but nobody with the solution.


Maybe you should try contacting WD’s Technical Support about this.

You can do so either by phone or email. To Contact WD for Technical Support