WD Passport refusing to initialize!

I have:

Western Digital My Passport Essential SE 1TB

Windows 7 Ultimate x64

Using default cable

Whatever I do, I can’t get the drive to initilaize. All the drivers are correctly installed. There is no missing or not started devices in Device Manager. In Computer Management, it shows disk as unallocated and not initiliazed. When I try to initialize it via Computer Management, it says “Media is write protected.” In command prompt, i tried using diskpart.exe to list the disk, which shows as online. When I select the WD drive and use the command “detail disk,” command prompt stops responding. I’ve tried this on my working hard drive and “detail disk” works perfectly fine. So I tried the command “attributes disk” and that shows:

Current Read-only State : No
Read-only : No
Boot Disk : No
Pagefile Disk : No
Hibernation File Disk : No
Crashdump Disk : No
Clustered Disk : No

I then ran the command “attributes disk clear readonly” and got “Diskpart failed to clear disk attributes.” 

I then tried 3rd party software, Minitool Power Data Recovery 6.5 to try to find and restore the lost volume/partition and find any data. That resulted in no partition or volume found and no data either. 

The drive clicks a few times when I plug it i, light is on. I’ve tried on 3 different computers all running Windows 7. I’ve tried hooking it up to a USB hub with an external power supply to maybe see if it wasn’t getting enough power. No luck. I’ve created the WriteProtect dword value of 0 in registry at HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies and restarted PC. This was no luck.

So I’m out of ideas of what can be wrong with this external hard drive. Is an RMA in order?


Tried running HD Tune, error report is all red (whole drive is bad sector). 

Also tried HDD Regenerator but said MBR is bad and never repaired any bad sector (not even 1 in trial).

Also tried using MbrFix.exe ( http://www.sysint.no/nedlasting/mbrfix.htm) but that resulted in the drive being write protected again! Ugh…

1 Like

Just a heads up, I decided to RMA it because anything and everything I tried to do failed. I see no other option. I spent too much time trying to diagnose the problem and fix it. Simply not worth anymore time.