WD Passport - not able to make exFAT OR FAT32


I bought a My Passport a few years ago to remove data from my PC. I then got a mac.

A friend formatted the WD Passport external hard drive and removed my files from it. It is formatted NTFS.

So I went to the instruction page on WD as and its give instruction on how to format tp exFAT or FAT32.

However when in disk utilities its does not give me the option too partition (this button is there but i am not able to click on it).

It also says I have no permission on the drive but i am guessing this is because the format is incorrect.

How do I allow it to be partitioned??

I have a Macbook pro from 2013 and am using El Capitan

Any help much appreciated

Step by step:

  1. Access Disk Utility.with your hard drive connected.

  2. Select the disk in the left panel. Click the root volume itself displaying the whole capacity as opposed to the individual partitions underneath.

  3. Go to Partition.

  4. Change the Partition Layout from “Current” to the number of desired partitions.

  5. Click on “Options” in the lower section and select Master Boot Record for FAT32 or eXFAT; select GUID Partition Table for the Mac-specific HFS+ File System.

  6. Back to the top, under “Format” select exFAT, MS-DOS (FAT) [This is FAT32], or Mac OS Extended (Journaled). You will see all 3 options, but an improper configuration based on Step 5 Options will result in a failed partition.

  7. Assign a name to your unit.

  8. Click Apply, accept the warning.

Thanks for that :slight_smile: However as mentioned it the partition button is not letting me as its blanked out/not possible to click on it. Any thoughts on how to remedy this?

Thank you :slight_smile:

Are you able to share a screenshot? I may be able to point out if there’s a parameter that needs to be selected. I’d also recommend rebooting your system and changing the USB cable.