WD Passport - Few of my files have a "LAST" file extension to it & it doesn't open

Hi guys! I recently bought a 1 tb wd passport. I manually stored all my files to this hard drive a few days back. Today I opened one of my folders and to my disappointment, I found out that many files like jpgs and Psd files had a “LAST” file extension to it and I’m not able to open it. Someone please help ASAP! I dont know what to do.

This looks to relate to the WD backup app (at least from a quick web search, which turned up articles like the one below).

What I would suggest you try is to take one of the files (e.g. PLQNT0.jpg5dfccfd4 above) - make a copy of it (do not work on the original) and try renaming it to its normal 3 letter extension (PLQNT0.jpg in this example) and see if you can open that.

The _LAST files look to be simple indexing files or something like that, and aren’t the files themselves (as you can see by their size).

1 Like

Hi Darren, Thanks for responding. I tried renaming a file but nothing happened. It’s still the same.
I’m not able to open up the PSD files below too. I don’t know what to do.

Are you using WD Backup?

Yes, I’m using Wd backup but the files I mentioned above were just dragged and dropped into the hard drive. I only backed up my ‘C’ drive (system drive) through the given WD backup software option.

There are other files which I just dragged and dropped and they are perfectly fine. Only one folder became weird like this. And unfortunately this folder has all my graphic design assets.

It’s not software I personally use so unfortunately I can’t give anything definitive. You could try using WD Backup to restore them, but perhaps others may be able to give you some assistance.

Do a web search for “_LAST extension files” and you can find a few hits on this topic which may also give some insight perhaps.

I tried searching for this extension but unfortunately there’s not a lot of information about it. I’m helpless.

And regarding the inbuilt wd backup software, I used that only for my c drive. All my other files were literally just dragged and dropped into the hard drive. And the screenshot above shows the files I just dragged and dropped. Some are perfect while some have this ‘LAST’ File extension.

I would expect the mixture of backup and drag&drop may be what’s confused things perhaps.

If you’ve dumped files into a folder that WDB is using as its destination storage area, it might well be keeping track of that folder (for version control or whatever) and so become confused when these other files suddenly appear and start thinking that they are files that it put there and needs to version track.

The only thing that I can think of is trying to use WDB to “restore” those files and see if you can have it do so to another directory (preferably a new one well away from anything pre-existing) and see if that gets them back. Beyond that I’d raise a support ticket with WD if you haven’t already.

The thing is I can’t use WD backup to restore because I manually just dragged and dropped those files. There’s no option in the WD backup software to restore those files. I think the only way is to contact wd support. Thank you so much for your help Darren. I really appreciate it! :blush:

It may well be that you’re hitting a bug (or a niche case at least) in WD Backup which would need to be addressed if it has tampered with files that it shouldn’t have done. As I said I don’t personally use it (and in any case I’m just another WD customer rather than anything official), so at that point I can’t assist more unfortunately.

In case you haven’t found it, their support portal is via the link below:

https://support-en.wd.com/app

Good luck with it, and as you can see from searching you’re not the first to see this issue.

1 Like

Hmmm… And Yes, I’m not the first. If others have gone through the same problem, I don’t understand why there were no answers resolving this issue online and the bug is still present. Anyway thanks for the help Darren.

Thanks guys for your efforts and trouble shooting. I too am experiencing the same issue. I have tried what I believed to be legitimate possibilities and arrived at the same results. Do either of you know of a 3rd party firm that may be able to restore my files? These files are critical to my business. The update to Windows 10 had to be the culprit, but shouldn’t have any effect. Also, my purchase was 02/2017.

Thanks in advance.

1 Like

I’ve noticed that each jpg_last file has an associated JPG#a#s# File file (#a#s# stands for a mix of letters and numbers). I discovered that if I add the extension .jpg to the name of that file (not the jpg_Last file) it will make it usable. Pain in the butt, however, it works, at least on my ASUS laptop…not sure how it will do on an Apple OS. If you look at the file name, you’ll see the extension is in there already, with extraneous numbers & letters after it. You can also just delete those numbers from the name and let the name end after the extension, but I found it was faster to just paste the .jpg at the end of each file name. Your choice, either works.

PS: same thing for AVI_Last files, add .avi…and assume the same thing for any file XXX_Last.

Hi, I’ve been a new Passport backup user for the last 4mo and started to investigate the file structure of the files located on the Passport device. I too did notice the _LAST file that appears on each of my backed up files.

When you open the “WD Backup.swstor” and then progress thru the folders, you come across a folder that has a History and another called Volume(+random letters). I found that the History folder contains all the previous copies of the files backed up + one identified as the _Last (this looks like a pointer since it is only 1KB in size)…In my case xls files with an added set of characters. (***.xlss5e336…) were included for the multiple previous files that were Modified prior to backup. What helps is if you select the Name column to force a sort sequence either up or down order for better visual instead of using the Date column sort. Since the multiple files look to be the correct size, I’m guessing that these too could be manually moved to the PC and Re-Named properly .

If you go go back the earlier Volume folder, here the actual _Last file is stored in its actual correct name ***.xls. I checked the dates for a match. I believe that this file can be manually drag and dropped back into your PC folder.

Now, I have not tried to do a Passport RESTORE, so I don’t know if the restore process would show a list of the previous multiple files…I would hope that this process works in-case you wanted to restore an earlier version. I presume that a proper Passport RESOTRE of an older file would strip out the long extension and just give you .xls file name.

As to why the original poster, Elshe got what she thought was her original Manual moved files with the _LAST, my guess is that maybe she also included these same files in the Passport chosen back-ups…don’t know why… I believe that she wants to do manual copy/paste of files stored. I plan to do Back-ups and also move files manually into a separate folders…hope I don’t see _LAST on these too.

1 Like

Thanks! I haven’t explored too in depth. I’m glad it stores earlier versions of files. I was worried it simply overwrite them with the latest update.

I had a different external drive that had a very simple file hierarchy and I could access my files at the top level. But unfortunately it’s full. I think it’s craziness to have to click through multiple levels to eventually get to the files and the file names dont make it intuitive to find them. I’ve thought about putting a shortcut at the top level, but don’t want to mess anything up for the backups.

If you have any advice on that, I’d welcome it!

mamski…I am a relative new user and brute force looking at files on the Passport can be frustrating. especially if one is not familiar with their Tree structure. For me, the _LAST gave me trouble till I found the original latest file in the Volume#### folder. To me, the History folder has previous versions, which could be lots of files (depending on how long you’ve been doing backups or how many times you modify the same file. I believe that the program uses the Modified date difference to choose the files (however I’m finding some of my June files are not being saved…I do a daily of my Documents folder). Sort your files by Name rather than date to see the multiple. I’m guessing that if you see many large extra older files, you could delete them. I don’t see that there is a way to ask for a version=say 5 to only keep the latest 5. But your device should not be reaching 1T of data, probably more than what stored in you PC.

You said you could not access the your top level folder(what do you mean) and also your 1T device is FULL…I too have a 1T and have started to notice the Free Space going down by Gigabites…Now, something is wrong, unless you are saving tons of *.mp4 movies of gigabyte size…I don’t and maybe you too. I need to post this question as a new issue later.

Responding late in case anyone else is new (like me) and tried to figure this out…

Right click the WD Backup in the task-bar. Select “restore files.” Then you can restore a selected, specific backup date’s backup files in their original file format.