WD Partition not opening

I am having wd elements 2TB external hdd.
4 months ago I partitioned it into 2 volumes.
It was working fine till yesterday.
Yesterday I copied 50GB movie into it while copying an error occured saying path not found. So I removed the usb cable from my laptop and reinserted it back but still it was giving same error.
Then I inserted and opened This Pc in explorer to see what is wrong. But now it was taking very long to show the disk capicity and it was loading and loading amd nothing was showing.

One of the partition is Bit locker protected and other is not.
Now everytime i inserted the same thing happen, the explorer keeps on loading and does not show anything .
I tried this hdd to open in others laptop and pc.
But the problem was same.
After inserting this hdd the diskmanagement keeps on loading and do not show any drive information in diskpart the same problem is there. When i unplug the hdd every information is showing but when i insert it back it keeps on pupulating data and do not show anything.

It is just showing the drivers in the explorer and nothing is happening on opening them the the explorer keeps on loading.
Yeaterday at night i run chkdsk command on one of the hdd partition after running for about 2 hrs it was able to detect 80KB of bad sector and correct them.
Then I was able to open them and run every files on the hdd but today the same problem is happening and now chkdsk command is also not working.
My drive is stable and does not have any type shock.
How can I get my data back, please someone help.

Hello mishracodes,

I would suggest you to test the drive using Data Lifeguard Diagnostics for Windows to check for any errors on the drive.

Refer the link provided below for instructions.