WD not popping up to enter password [Huge Problem]

the disk spins…but i can’t see it in ‘Disk Utility’…

it’s password-protected and i can’t get the password dialog anymore


Does your drive has a VCD? Is it showing? if that’s the case you can open it and run the WD Unlocker

no i wish it was nothing appears anymore…

do u know how to make it appear so i can unlock?

Hi again

Do you have a desktop or laptop computer? if you have a desktop make sure to plug the usb cable on a port located on the back of the computer, if you have a laptop plug the usb cable directly to the computer (dont use any usb hub), maybe your drive is not being recognised on the computer and that’s why the unlocker doesn’t prompt

i have a laptop and the drive is suddenly out of nowhere not being recognized…i’m using the same mothod of connection that worked for me for almost 10 months…

You can also try with another usb cable or test the drive to see if has bad sectors or data corruption you can use TestDisk you can download it from this link :  www.cgsecurity.org/wiki/ TestDisk _Download

i tried it on a PC and i saw it in disk management and tried TestDisk and it was 100% healthy again…HELP !

I forgot to ask you something very important, do you have WD Smartware installed on the computer you are trying? if not as soon as you install Smartware and plug the drive you will have the unlocker window

i do have it…and whenever i open it nothing happens it just shows the contents of my mac…

Did you updated the firmware lately? if yes, then try the drive on the PC you mention before, update the firmware and try it on you mac. 

i have the latest firmware i’m afraid…it seems WD products don’t like macs…

Since we tried different things, that would be the last we can try, but you already have the latest firmware update on your drive,  if you want before trying that option you can wait until another member on the community tells you another option.-

thank a lot :slight_smile:

let’s hope other ppl try to help!

Does the drive show up in Disk Utility (Mac) or Disk Management (Windows)?  If so, (in Windows) is there a black bar or a blue bar?  I’m not sure about Mac, but you want to check to see if the partition has been corrupted.  If you’re in Windows and the drive shows up in Disk Management, with a black bar or showing it needs to be initialized, then the drive partition has most likely been corrupted.  You will need a utility to restore the partition - if it can be restored.  Otherwise, you need to repartition and format.  That of course will destroy any data on the drive.

well as i recall the bar was black in windows but i don’t want to restore or format i want the data badly

If you are not getting a VCD, that means your computer is not seeing either LUN.  This is not good.  If you have tried a different USB cable, you may want to contact support and have them send you a power-booster USB cable (USB Y-Splitter).