WD MyPassport SSD Wifi only USB 2 Connection when connected to PC


When I connect my ‘MPW SSD Wifi’ to my PC with Windows 11 using the supplied USB 3 cable, I only get a maximum transfer rate of 37 mb/s. Under USB Tree Viewer the device is listed under USB 3.10 eXtensible Hostcontroller, but in the description it says USB Version 2.1.
In the device properties I discovered the following info at the event log:

The device settings for USB\VID_1058&PID_2601\313735303737343231353231 were not migrated from the previous operating system installation due to a partial or ambiguous device match.

ID of the last device instance: USB\VID_2833&PID_0182\1WMHHA481N2222
Klassen-GUID: {36fc9e60-c465-11cf-8056-444553540000}
**Item Path: **
Migration Rank: 0xF000FFFFFFF122
present: false
Status: 0xC0000719

Tested the same port with other USB 3 devices, they are recognized perfectly as USB 3.
Have also tried another port and another cable, unfortunately no change.
In the Bios settings XHCI Handoff and USB Legacy Mode is enabled.
Firmware is up to date. Also tried on Windows 10, no difference.

I also tried to roll back the device to default settings via browser settings, and also formatted the disk to ntfs and even exFat, all these steps doesn’t affect to the read- and write speed of the drive.
I also connected the device on my macbook pro to see if its a problem with operating system, but the speedtests on Mac OSX also showed the same slow speed.

Can you say that it is 100% a hardware defect, maybe on the Hardrive controller itself?
Or is there another way to fix it, by a certain driver maybe?

My last try was to open the MyPassport Case, take out the SSD which was a Sandisk X600, and I tried it on another external 2,5 case with USB C Gen 3.1 connection, and the speedtest shows now 330 MB/S read and write speed on the same USB 3 port with USB C to USB 3 cable.
So, can you say that it is the controller of the WD MP SSD case that is the bottleneck?
Is it maybe a energy problem, cause the case needs lot of power and the USB 3 port maybe doesn’t deliver enough to get fullspeed?

Hi @ewok79,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Thx, I will try that. Just wondering if anyone else had this problem and maybe someone knows a fix for it