WD MyPassport 2TB installation failures

I have one WD MyPassport 260D - 2TB drive. I now have another 2TB WD MyPassport 2626. Message when I try to install WD Discovery for Windows "Installation failed. We are experiencing issues. Please try again later." I have retried on many occasions, but will not install. It goes through the various processes and says it is downloading and extracting, but then fails at 45% of installation. Is it an issue with WD or could having 2 different MyPassport drives be causing an issue?

EDIT I had Windows check for updates… there were updates that needed to be installed. Once they installed & the PC restarted, the WD Discovery app installed just fine. shrug

I am attempting to install the desktop app for MyCloud Home (Windows 10 Home), and I’m getting the same thing. The first time, it froze at “Installing 18%”, so I used the Task Manager & force stopped it. When I tried installing a second time, it downloaded just fine, but when it started the install, it jumps to the “Installation failed. We are experiencing issues - try again later” notice. I also tried deleting the first install file & downloaded a fresh installer exe file. Still failed. It’s a brand new laptop (unboxed it today), so no previous WD software/utilities have been installed, and I made sure to turn off the auto-installed McAfee Security stuff. Still no dice.

What’s weird is, I just installed it on a different, nearly identical, laptop just 4 days ago & it installed perfectly. No issues. But now… nada.