WD Mycloud not recognize by backup softwares

Hello
i have try during 3 hours but impossible to find the solution (sorry for my english)
So the problem is simpe tot explain : i’m under W10, under wifi network
The harddisk is recognize ok by windows explorer and i can open HD configuration in chrome no problem
BUT HD IS NO LONGER recognize by backup softwares (the backup of windows10 and other softs)
Just indicate : no disk available or no access to network place

Thanks for help by advance :wink:

What backup software/application are you using?

Hello Bennor
When i bought HD i used Acronis (free) with success.
Acronis stop it’s free offer after the perio
SO i went on Microsoft W10 backup (files history) it was working till end of august
Now i have this problem explained
For me Acronis is good but too expensive for personnal use (and it’s a price every year not 1 shot)
Maybe you have idea of the problem or cheap but good backup system (what i want is simple : of my laptop HD have a problem or if i lost my laptop or anything : i want to be able to buy a new laptop and recover all my files and software)
thanks :wink:

One troubleshooting step. Ensure SMB1.0/CIFS is enabled in Windows 10. Probably is but always good to double check when one has trouble accessing a network attached storage device like the My Cloud.

When using Windows 10 Backup and you select Add Drive, make sure to select the Show all network locations option to see network drives. One may also have to “map” the My Cloud Share to the Windows 10 computer.

There are several free backup software alternatives that are available. Here are just a few.
Macrium Reflect: https://www.macrium.com/reflectfree
EaseUS Todo Backup: https://www.easeus.com/backup-software/tb-free.html

Thanks a lot for Help

SMB is enabled

i can see HD in explorer

i can access to it via chrome (but it’s slow to access) with admin/mypassword

BUT windows 10 backup does not recognize any HD (no disk available)

You are seeing the My Cloud listed under Storage, but is there an entry for the My Cloud under Computer (like the screen capture below shows)? If not, as a troubleshooting step temporarily disable your security and or firewall software (if any installed/enabled) on the Windows Computer and see if that is blocking the My Cloud from showing up under Computer.

Or “map” a My Cloud share (see link in prior post for directions) to the local computer and see if the backup program will see the Share and let you use it as a backup location/target.

Yes with firewall windowsdefender desactivated it appears now in computer
BTW i can still not map the HD and still not recongised in backup drives

Sorry it’s my mistake : there is an element under computer but it is not “WDMyCloud” like in storage

One other troubleshooting step. Ensure the Network Profile is set to Private and not Public.

One maps a Share on the My Cloud not the entire My Cloud itself. The Backup program will see a mapped Share and include it in the Select a drive listing. In the examples below the Public (Z:) drive is the mapped Public Share from the My Cloud.

Just to note I’m using Windows 10 Home Build 19041.

interesting but

Ensure the Network Profile is set to Private and not Public

how/where to check that ?

(please note same W10 Home 19041 ;-))

i’am in private both on wifi link and in CPL link in the internet box

Not sure what CPL link is. Generally one should use one network connection (either Ethernet or WiFi), not both at the same time. Using both can have issues under certain network configurations.

Other troubleshooting steps. Ensure all devices (My Cloud and computers) have the same Workgroup name. Ensure all devices are on the same IP address subnet. Example all devices have an IP address in the 192.168.1.x range. Assign a static or fixed IP address to the My Cloud either using the router’s administration interface or within the My Cloud Dashboard > Setting > Network section. Check the router settings to ensure the router isn’t filtering or blocking access between network clients (sometimes called Client Isolation). Or that the router isn’t using some kind of additional security/antivirus filtering that would affect network clients. Disable any third party anti virus or security software on the Windows Computer (this includes Malwarebytes, Norton/McAfee/Avast or other antivirus/malware prevention programs).

Point is, some setting somewhere on your network or more likely on the Windows Computer itself appears to be preventing your computer from properly accessing the My Cloud.

Access the My Cloud by it’s IP address in Windows File Explorer. Example \\192.168.1.100 and then right click on a Share, from the listing of Shares, and select Map Network Drive to start the drive mapping process (as indicated in a previous post link on how to map a Share).

Example mapping of a Share via IP address (through Windows File Explorer):
mapshareexample

“”"""“YES”"""" GOOD now by filling the “\IP\Public” in mapping process :smile:

Bennor great thanks for all and for your patience
The fact is that network configurations are difficult to understand for non-informatic people
i’m geek in drones , not in networks :wink:

I hope this post will keep in line for others to help (and for me if i need later…)

Are you WD official support or just "anonymous :wink: ?

Not WD official support, just a My Cloud end user like most everyone else who comes to these support forums.