WD MyCloud is not working :-(((

Dear Friends:

i am writing here because i am desperate :frowning:

of course i have already initiate a ticket with the Customer Service, we have been writing each other almost every day in the last week but until now no solution has been found :frowning:

please allow me to quickly describe my issue and hopefully there will an angel who could suggest where to look for solving:
i have installed MyCloud 4T device, plugged to my home network, configured it through the Dashboard … after many check and tries last Thursday i decided to back up everything and reset to factory setting, clean up and re-start from scratch … configured the MyCloud devise, upgraded the latest firmware, create some Users and Shares, got code and allowed my iPhone and iPad to cloud access …

  • it works within my home wireless network
  • it works if access by internet browser
  • it does NOT work if i try to access from my iPhone and my iPad, always same last week message “Drive offline” - i have tested with iPhone on Cellular Data 2G and on another outside wireless WiFi, i have tested with iPad on another wireless WiFi with and without VPN
  • it did work when i gave the access code to a Customer Service representative, he tested with his mobile phone and he uploaded a picture on MyCloud
  • i have the latest iPhone WDMyCloud app - 4.4.2

where do you think is the problem? since MyC;loud is working fine through the online website i think it should not be a problem of MyCloud 4T configuration … since the assistance guy access it should not be a problem of network configuration …

thanks to anyone who may have a good idea to move forward

Vito

Hello,

Did you check the remote access settings on the unit and port forwarding on the router?

Dear ERmorel,

thanks for your reply

  • yes, remote access is set to ON
  • FTP access is set to OFF
  • sorry i dint know how to check port forwarding in the router, could you tell where to look for …
  • please keep in mind that the iPhone app works within my home network Wifi and also WD Customer service representative helped me to test from his own iPhone and he did access MyCloud and update a picture on MyCloud

i am very frustrated, i have reset to factory setting 2 times now … i can not figure out what is missing :frowning:

thanks a lot

Vito

It has something to do with your iPhone and iPad. Neither can find your My Cloud so you get this message, I do, too, sometimes. So, relax and feel less desperate now. This can be figured out, I believe.

OK, here is how I just now replicated your problem. I have two WD devices setup in the app. One is the My Cloud and the other is the WD wireless drive. So, my app opened to where in the app I last was (looking in the My Cloud) and I did not get that message. I tapped the 3-bar menu to get to the hidden menu on left and switched to view from the My Cloud to the wireless drive and closed the menu. Since the wireless drive is not turned on, it can’t be found and I got the message “Drive offline”. Of course it is, it’s not ON! Yes, this happens to me often when I have been using one device and forget to Select the other in the app menu.

If you have more than one WD device to control in your app, the same thing will happen to you. So, tap the 3-bar menu button and be sure the My Cloud is selected, and has a blue bar next to it. Even if you only have the My Cloud check it anyway. Do this for both phone and pad.

Maybe you didn’t even SEE the My Cloud in the app menu, and it is because you likely never did ADD the My Cloud to either the phone or pad app. So, in same menu ,tap Manage devices, and add the MC to the device! Do it on both phone and pad. Remember to tap Done after adding device. Now, you should see the MC on the first page of this menu.

Hopefully, this helped. If not, further investigation is needed.

thanks for your detailed reply

i will explain what is happening to me step by step:

this picture show what i see when i launch the iPhone app
(http://www.donatiello.info/test/mycloud/WD_launchingMyCloudApp.PNG)

after 2 minutes waiting i receive the first Error message
(http://www.donatiello.info/test/mycloud/WD_firstErrorMessage.PNG)

then i touch the 3 bars icon on the top left corner of the iPhone screen and this is what i see
(http://www.donatiello.info/test/mycloud/WD_opening3barsMenu.PNG)

the first device from the top, WDMyCloud has a blue little bar on the left of it, i click on the right “setting wheel” to open and i am getting this Error message
(http://www.donatiello.info/test/mycloud/WD_1stDeviceClickSettingWheelError.PNG)

(http://www.donatiello.info/test/mycloud/WD_1stDeviceClickSettingWheel.PNG)

back on the 3 bars left top menu, i click on the second item “manage deices/services” and this is what i get
(http://www.donatiello.info/test/mycloud/WD_2ndManageDevices.PNG)

if i click on Add manually > WD drive it will ask me again the Activation Code and i dont need to re-do it … the second My Passport Wireless i dont have so i dont click it …

on the bottom of this menu, last item is Setting and this is what i get if i click on that Setting
(http://www.donatiello.info/test/mycloud/WD_clickSettingBottom.PNG)

i dont know if my experience is exactly as you kindly tried to replicate …

is there anything else i can do to further assist your investigation???

many thanks for your time

Vito

OK, I just replicated the whole sequence of screen shots by again, going to my device that is not on. At one time you must have connected to the MC with your phone so you are seeing a menu left in memory, but you are not connecting as we can see.

OK, ready for Part 2 of the fix-it adventure?
You must have confused or lost the MC IP address from what it was with all the turning on and off you were doing, and the iThings have the wrong IP, I think. So, lets re-install the MC app on both, one at a time.

You know how to do this I hope, but if you don’t ,turn off app completely then go find its icon to restart app, instead of tapping it, hold down on it until it wiggles and shows an X. tap that X to un-install it.

You could re-install it right away, but let’s reboot the phone first, so hold down the top black on/off button a short while until you see a slider on screen and slide to turn off and reboot phone (or Pad)

Give it a few moments to be off, then turn it back on with the same black button, holding it in until you see the apple logo and then release. It takes a while to start back up, and you may need to press the black button to get the screen back if it stays dark.

Now, go reinstall the MC app at the apple store. Once installed open the app. Check if you can now access the MC. If so, great and do same procedure to other iThing.

If this did not help, it is time for
.
Part 3
Turn off the app completely again and leave iThings on
Turn off or unplug your new MC, Turn off your router and modem.
Count to 10 and turn on the modem, then the router back on with a few minutes between each
Once these devices are working well again, Turn the MC back on and wait until fully booted
.Now, turn the MC app on iThings back on
Does it all work now?

Gotta go now and will check back in about 10-12 hours or so. Good luck with it all.

thanks for your detailed email

  • i did connect to MC from home network and that maybe the reason why there was something in the memory

  • forgive my question: what is “iThings”? i am afraid i have misunderstood something …

  • forgive me again, which one is the modem and which one is the router between my TP Link wireless and the other device China Telecom installed behind the main door?

Guess what. I am still awake here on west coast of US, I saw your message before heading to bed, but before I go, What do YOU think an iThing is? (All we have been talking about here are iPhones and iPads; i.e. iThings!
Here is the word used in a sentence. You walk into an Apple Store and all you see are iThings everywhere! (aka iDevices, iGadgets ) got it now?

Difference between the modem and router? Well the one with the antenna is the router or it could be a combination gadget that includes both devices in one. No antenna showing? Maybe one device says MODEM on it, the other says ROUTER on it, one box may be for your internet phone, or for a home security system. You know what you have, not I, but you need to know what is what when you are told to turn of your router, and it will happen from time to time, or you will have China Telecom coming over often. Call them, maybe they know. Be care what you unplug; know what it is.

I can see you are going to have lots of fun with your new My Cloud. At least you came to the right place, this forum, for help.

Did you go to WD main website’s Support and download the complete user manual for you exact My Cloud? You need it.

Later.

Dear Mike (is that your name?)

i have got about “iThings”, sorry i haven’t heard it before, maybe here in China is not popular yet

i m also confused, are you a normal user (or better said advanced user) or you belong to WD Support team?

thanks

Vito

Vito, I am back to forum for the next few hours if you need me. Yes, I am a user like you. There are not too many WD folks in here other than moderators. To get WD Support you need to go to that section of the WD website.

I don’t know what you have done with the equipment since our last visit. If nothing, then just skip the router/modem steps and just shut down your My Cloud as discussed, let it rest a few moments then check it with your iPhone/iPads (i.e. the iThings) and see how the things work after you uninstalled/reinstalled the My Cloud app on them all. IN other words, skip over the modem/router reboot, but do the other stuff.

dear Mike,

thanks a lot for your volunteer time here

as i have said earlier i am also talking the the WD Support team but so far they are not able to find a solution to my case … i offered them a user and password and they tried to test and they were able to get with WD engineer iPhone inside MC and upload a picture but after that we are not making progress …

going back to my case, i did follow your instructions last night

i turn off the fiber modem, i turned off the wireless router, i delete the iPhone app and i turned it off

after few minutes i turned on first the fiber modem (fiber cable goes in, ethernet cable goes out)

second i turned on the wireless router

third i turned on my iPhone, i re-installed the app and i tried to login to MY, i know if i keep the WiFi on it will find MC directly, so i turned WiFi of, i provided username and password, i provided a new access code and i could NOT access MY … these are the screenshots i have got

do you have any other suggestion???

many thanks indeed

Vito

I’m here again. Nice pictures!

OK, I followed all this and glad you figured out the router and modem. I am almost sure you actually turned them OFF, either by a switch or by unplugging them from power if there was no switch. I sure hope you didn’t unplug or disconnect any other wires to units, just the electricity to power them Correct?

OK, here we are, with rebooted modem, router and iPhone, The one other thing that is important is to reboot the My Cloud. So, if in the My Cloud menu there is a way to Reboot, let’s try that first, (Maybe look in the MC Dashboard on PC) and if things do not improve still you will have to figure out how to power it down with the instructions you have at hand. This may or may not be in Dashboard, Otherwise, there maybe instructions at WD site how to do it I can find and send to you in next message.

There is one last thing if all this does not fix things and that is reset the MC to factory defaults in such a way that any data you have on it will be OK; we would just reboot the system.

Hold on a second, power down may not be necessary if resetting the MC works for you. I will check at WD site and be back in a half hour or less with instructions , so just stand by. . . .

hi Mike,
sorry in my previous post i forget to mention…
after modem and then wireless router, i rebooted MC … then i reinstall and launch iPhone app …
all without success :-(((
i did “factory setting restore” last friday and since then i have been looking for a solution :-(((
thanks for your time
Vito

OK, back with instructions for Resetting/Restoring factory settings for My Cloud. First of all I presume you have the basic 4TB My Cloud and not the MC Mirror or anything else Confirm for mw what you have.

This is the link to the instructions at WD site. Look through them and we are going to perform the most basic restore that does not delete any of your data. It is in the first instructions on the list called “My Cloud System Only Restore”

It says right at first there is a way to press in the rest button on back, and I suggest that way. Most people do it that way. I have had to restore mine once before, and many others have, too. So here is the link. Read it and get back before you begin. I will check back often the next hour or so.

Be sure to click on what version OS you have OS3 or OS1. YOu have a new model, so likely OS3. Let me know what you have.

Did WD guide you through the Restore? I hope all you did was the System Only restore.

Well, it won’t hurt to restore one more time because the iPhone still can’t find the MC, While doing restore, have the iPhone app completely off again. After, MC is completely rebooted, you can turn phone back on and see if you can connect to MC. Be sure you have the MC selected in the iPad 3-bar menu again with blue bar next to it. I did not see tha in the recent picture you sent.

Are you ready to try again?

Vito, it is after 1am here, and likely after 5pm where you are, and since I was up too late last night, I will be in bed tonight in an hour. I will check back before I turn off PC for night and hope to get some good news from you. Later, Mike.

Dear Mike,

thanks for your passionate support till now

regarding “restore”, i have done last weekend, i actually factory restore (i did not have important data, i was still on trial phase so i didn’t mind to erase everything)

the last 2 days i was helped by the WD Support team and i would like to say a word on that, while i spend more than a week with emails back and forth without hitting close to any result, finally yesterday someone form the support team called me by phone and offered to guide me through … i accepted the help, i gave them trust to control of my computer and MC setting and finally the nightmare is over - not sure this is my personal opinion - maybe the case was escalated to a senior engineer and i am very satisfied to have found a fix

i would like to better describe my problem and the solution, in case it might benefits some one else, but please forgive my poor technical language

according the WD Support Team, my problem was a so called “double layer” network, the internet provider (China Telecom) installed a cable modem just by the door of my apartment in which a fiber cable comes in and a lan cable goes out to the other rooms of my apartment … in my bedroom i have installed my wireless router and at one of the 4 doors i have the lan cable to connect to MyCloud … sorry i dont know if it is port forwarding issue or a uPnp, i dont know these matters … what i can say is that MyCloud was assigned IP 192.168.2.1 and the cable modem was assigned 192.168.1.1 and such configuration caused conflict and didn’t allow my iPhone app to get in …

WD Support engineer helped my to change such configuration, i have to say that problem can not be solved by a normal person because it requires a good knowledge of networking, configuration modem and router and being super familiar with IP number assignment, he got into my wireless router and change several settings and numbers, also the intervention of China Telecom technician was needed in order to get inside their cable modem and change that configuration as well

in conclusion was the engeneer told is that he changed the configuration, the China Telecom cable modem from primary router to switch and my wireless router from secondary router to primary router

in the end all is good, thanks to all for your support

Vito

VIto,

I am REALLY glad to know your issues have been resolved, and that there was nothing wrong with your new My Cloud. I followed your explanation well, and am relieved to know there was an IP conflict I was helping to resolve, but from what you say, this problem was bigger than both of us. I am glad to know, too, that WD Support came to the rescue for you. Good for them!

So, further good luck to you, and now you can enjoy your new My Cloud. Hopefully, any other questions you have will be a lot more simpler to resolve, so if you have further questions be sure to come back to the forum if you need too, I will keep any eye out for any posts from you!

One last question for you. Your name doesn’t seem to be Chinese, but rather Italian. Are you an Italian citizen living and working in China? I ask because I am 50% of Italian decent from my father’s side. :slightly_smiling: