Wd mycloud desktop apllication editing and saving files

when i use wd my cloud app for windows it lets me dit the files but sometimes it doesnt let me save them.
i have tried many times to edit the files directly in my cloud app and then click the save bottom on the left up corner.
I closed the file and them i open it again and the changes havent been saved.
this is disturbing because everytime i change the file i have to check it twice and edit again and again.
Has someone encountered the same problem?
Any solution?

What type of file, with what app? What operating system in Windows do you have? An image would help some.

I m using excell files, and when i finish editing i click on the save button and then i exit. i open it again the changes hasnt been saved. sometimes saves and sometime doesnt. i m using the wdcloud app for windows.

Are you accessing the My Cloud on the local network using the Desktop program or remotely?

If locally then don’t use the Desktop program, use Windows File Explorer or Mac Finder instead. For easier access to a local My Cloud one can map the drive.



I m using remotely, when i m local it works fine.
first i tought maybe was the problems with the internet speed or somehow but i tried in other places and its the same.
sometimes saves the files i edited and sometimes it doesnt. so every i edit sometime i have to double check.

1 Like