WD MyCloud and Boxee Box problems


I used to have an Imac connected via a network socket to my gigabit router and from that to another network socket and to my Boxee box. That worked perfectly no problems at all. Never any buffering when watching a movie and movies starts almost instantly.

Now I have bought a WD MyCloud 4TB instead. Connected it the same way via network sockets - Router and to the Boxee Box.

I have tried reach the files on NAS via SMB and NFS and both works. I can see the files, I can start the files. No problems so far.

BUT a movie takes like 10-15 seconds to start. I can live with that but then the movies need to buffer like every minutes for 5 seconds. And I can’t live with that. Is the WD Mycloud so slow that it can’t transfer a dvdrip och a bluray rip in the speed needed to not have to buffer all the time?

Any tips? If I can’t get this to work then I have to return it.

No one has any idea what to do?

There can be a couple of reasons and its hard to diagnose what the fault might be without more information.

  1. Are you connecting via wireless or using wired lan connection.
    If wireless, then you may have a weak signal and the bandwidth to view the movie isn’t enough and so that is why
    a movie is slow to start and you’re buffering the movie all the time.

  2. Assumed you are on a LAN (Rj45) wired connection. People are experiencing a slow mycloud box because the WD thumb-nail scanner process (convert/ffmpeg/photomerger)
    is consuming all the CPU in converting your photos and movies to allow thumb nails with navigating WD My Cloud remote software. When this process is running it typically consumes 100% CPU, it leaves little CPU left to server your files via Samba (smbd) and  that can be why you get limited download speed (even though its dual processor, ffmpeg will use both CPUS, that is ffmpeg is multi-threaded). 

Since I don’t want to use my cloud remote software or see thumb-nails, I’m willing to ssh into my cloud, and disabled those services.

However, if your not technical, then this option is not available to you. WD should give you the ability to turn of the scanning within the GUI UI.  People have suggested turning of Twonky Media Server to prevent scanning,
but I think this is only a partial solution as WD scanning still occurs.

So what’s your solution? Either check your drive is working/scanning by touching it and you should feel the drive ticking away.  This can imply that my cloud is either scanning or server a file onto the network.
You can wait for this scanning to complete and you can view the progress in the GUI UI, or try turning off Twonky and see if this works. If there is no scanning, and you’re drive isn’t working, and your network connection is fast; then contact WD support…

My diagnoses is purely speculative.

1 Like

Thank you Rubikcubic.

I’m using a LAN wired connection. Yesterday I tried to put my WD My Cloud directly into the router but that didn’t help.

I have only transferred like 60 photos and 4 movies to My Cloud and did it 2 days ago so it shouldn’t convert anything more to thumb nails now.

My connection is good, route ris good, tried different cables etc and still same problem. Could try to connect directly to my Boxee box but that is a solution I don’t want.

Have to call the support today again but I’m pretty sure they can’t solve my problem. Either I have got a malfunctioned product or the product is not so good from the start. Will buy another brand and see if that works better.

What do you mean Sam?

Is it because I have a boxee box I need another NAS?

Any to recommend? Not to expensive.

Panicmango wrote:

What do you mean Sam?


Is it because I have a boxee box I need another NAS?


Any to recommend? Not to expensive.

I guess he thinks that someone who can afford such a fine audio box would better buy a fine NAS from a manufacturer who knows to make good firmware :open_mouth:

Synology, Netgear, Buffalo etc…

1 Like

Haha Boxee box is not fancy or expensive. It is just no tproduced anymore but it does a great job for me.

Just ordered a Buffalo linkstation 420 instead and I’m returning my MyCloud tomorrow. Really hope the Buffalo is better.

Hey there, 

I just registered to the community as I have the same problem. this might be a quite old post but I hope you see this :) 

I have exactly the same system at home, I have a WD MyCloud 3TB and a boxee box which is sadly not produced any more in Europe. I was using Boxee media manager before and could stream movies from my PC or Lapop over Wifi with no problem using a Netgear N600 router. (I have never tried to stream movies bigger than 4GB)

Then I bought WD and started storing movies on it and streaming over wifi and still no problem. (I have 100Mbps internet speed and I get about 30 over wifi)

Since I got a huge screen I started to get bigger files more than 10-15GB. Now i have a problem. I tried everything!! connect boxee with cable, changing the cables, disable media streaming of NAS, restarting all devisec, factoy reset devices, installing boxee hack new OS, leaving home smoking a cigarette and trying again! :smiley: none of them seemed to work. Besides, my boxee box is also cannot find any media source at all and I had to give the WD IP manually (before the crisis started to happen it could find PCs through boxee media manager and also the NAS through NFS)…

Now I was wondering if you have solved the problem buying Buffalo? 

Hope you reply to this as this is realy annoying! 


the wifi is probably the issue, a 15GB 2 hour movie needs 17Mbps. when you start using that much of the bandwidth it doesn’t take much to cause issues plus the is an average speed some scenes could use much more. I would look into a cable connection or one of the faster wifi speeds

I don’t see why you mentioned wifi is the problem… I used to use wifi and was getting about 30Mbps and everything was fine with smaller files. Then since I got problem with big files I started using boxee wired. I checked the speed with Speedtest.net and I got almost 100Mbps on Boxee. So I don’t think it’e the speed. 

P.S. I started to think that as I put more in WD Mycloud the buffering pause happens more often… juts a feeling… I’m not sure

OP, what firmware are you running?  I have the 3TB  (and a Boxee!) and with firmware v03.04.01-230 I don’t have any streaming issues.   I briefly tried v4 firmware, but it was horrible.  Also, I disabled the crippling services.


As an aside, WD really needs to pull their heads out, admit that the product as it stands is a failure, and start removing the “features” that make this thing broken.   Indexing…kill it now, WD.