WD MYCloud always spinning

My problem is that my WD Mycloud 4TB drive almost never goes to sleep, i read alot about this particular problem and have many difficultis to solve my problem, i have my working desk in my bedroom so it’s obvious that at nights i can hear him spinning.

Any help is much appreciatted. I have a mac and not so much knowledge about terminal code writing stuff - read about them in other topics

Thank you.

What version of firmware?



Thank you

If you have read the other threads/discussions then you have the information you need to try and tackle the sleep problem with the v4.x firmware provided you have enabled the Sleep option within the My Cloud Dashboard > Settings section.

You will have to copy and paste in, or type in, the various lines of code into the two or three files mentioned in other discussions. Do an internet search to see how to use SSH to access the My Cloud once you have enabled the SSH option in the My Cloud Dashboard > Settings section. You may be able to find a GUI type program like the Windows version of WinSCP that makes using SSH a bit easier.

For example there is a number of posts in the following thread that detail the code and file location some of us are using with the latest v4.x firmware:


You will have to do some experimenting to find which code works best for your device. I have also found that to get the best sleep time to turn off or put all computers on the local network to sleep when not in use otherwise they may “tickle” the My Cloud (or Samba/SMB) keeping the My Cloud from staying asleep.