WD MyCloud 3TB New - Red Light Problem

Hello everybody,

I just bought a 3TB My Cloud and never success to connect it.

When I plug it on the router, firstly is the white solid LED for 1 minute.

Then appears the RED solid light and staying as.

I tried to reset it. I tried to plug it on different routers, different networks and with different cables.

All is a bitter failure …

I tried to post a request to WD but no response yet.

What are you thinking with my problem ?

Am I ready to send it back to the shop ?

Thanks all for your help

I’d consult the users guide, if it doesn’t offer a working solution (troubleshooting section).
If not, I’d take it back asap and get a refund or new working cloud :slight_smile:
The startup should take approx. 3 minutes and then the light should stay solid blue…

Make sure the unit is connected to your router with an Ethernet cable that is working (test it with a computer).

Try a complete reset: unplug the power, depress the reset button at the back of the unit, then, without releasing the reset button, plug the power back in and hold reset button for at least 40s.

If this doesn’t solve the red light issue, you should return or RMA your unit.

1 Like