WD My Passport Ultra not working after putting the computer to sleep while it was still connected

Hi everybody!

I have problems with my My passport ultra, it started with it only working with usb 3.0 ports. When i bought it everything was fine it worked with 2.0 and 3.0 aswell, but usb 2.0 devices slowly started to not recognize it (i don’t think it was the cable, becouse i tried using usb extension cables and it had the same problem) , i had to connect to these devices 2-3 times before they recognized it. But this wasn’t that big of a problem. Now it isn’t working at all. I plug it into my usb 3.0 laptop, and i hear the “connect” sound in windows as normal, but it doesnt show up in my computer.

It happened after i had it plugged into my laptop, and i closed it (putting it to sleep) without unpluging. After that i think i removed the device before i started the laptop again. Now the drive seems to be stuck at that state it was put in when the computer went to sleep. Now i plug the drive in, it starts flashing, buzzing and after a while it seems to shut down and starts blinking.

It shows up in Devices and printers like this:

I installed the driver several times, in every way possible. :frowning:

(this driver right here: http://wdc.custhelp.com/app/answers/detail/search/1/a_id/5419)

It doesn’t seem to have any information about the drive:

Screenshot 2014-11-16 14.44.01.jpg Screenshot 2014-11-16 14.44.03.jpg

it shows up the same way in device manager aswell, with the yellow exclamation mark as “other devices”.

I would appreciate any help as to how i should make it work again to get my stuff off of it.

Thank you!

  • David

Hello davekarsai,

Welcome to the WD Community,

Are you able to test the drive on a different computer?

See if the following link helps.



Thank you for your help!

Yes, i tried it with my friends computer and it showed up, i formatted the drive with his laptop, but it still wont show up on my machine. It shows up exactly like before the formating on my laptop.

Any ideas?