WD My Passport shows 'disconnected' since changing Mac to Windows


Successfully followed the links on the WD My Passport website to delete all data to enable me to change from a Mac to Windows. Since then whenever I try to back up to the drive on Windows 10 Home, it shows the drive is ‘Disconnected’.

I’ve sought advice from WD and followed their advice and links, but no further forward. Have run the two ‘Device Status’ checks and they came out as working OK, but when I tried to do the ‘Complete Drive Status’ Test it showed ‘Complete Drive Test Failed’. I did this complete test as the WD still wouldn’t back up to Windows and showed ‘Disconnected’ still after initially showing 'Backing Up.

UPDATE the Complete Drive Test has now run and shows that it passed the procedure. Why won’t it then connect the My Passport drive to the laptop (as shown in Disc Management as being present)?

Can anyone please, please, please advise how I connect the drive again?

Thanks in advance!

Hi @Kimina,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Yes I did, but after lots of their helpful attempts to possibly fix the issue, they advised the drive might be faulty (and out of warranty) …but that was before I ran the full drive test and found it to be working correctly!

It’s just getting the drive to connect again to the laptop that’s the issue.


UPDATE - have now replaced the cable with a new one, but while the drive shows up in Device Manager, it’s still not connecting. It shows that everything is working normally, current drive is latest one, so I’m at a total loss why the correctly working drive won’t connect to the laptop!