WD My Passport not working on specific computer

Hi All,

My WD Passport is not working on one (only) of my computers.

I have looked at other posts on the forum, but they seem to be about the drive not working at all.

My drive works fine on the computer I initally ran it from, but it doesn’t work on one of my other computers

Both computers have same setup - Windows 7.

The only difference is that the first computer only had Drves C and D such that Passport took E and F.

The computer it won’t run on has drives C,D,E,F,G

In Computer>Manage, Passport Smatware CD shows as Drive H:, but data drive shows as unrecognised. Shows as Disk 1 but it won’t let me assign a drive letter.

I tried renaming E,F,G to X,Y,Z but that didn’t work.

Please don’t advise me to reformat the drive or use file recovery software. I can get the files off by using my other computer, I just want to be able to access the Passport on my main computer.


There is chance that this computer has limited power in its USB ports.  You may contact WD support and ask for a USB Power Booster cable.

Hi Vadir

Thanks for the suggestion - I’ll give it a go.

This could be on the right track as drives didn’t display at all when I connected passport using a USB extension lead.


WD also recommends not using cables longer than the one supplied or a hub.


Hi guys,

thanks for suggestions but no luck !!

I tried a powered USB hub, which didn’t help.

In the end I gave up and reformatted the drive using the HP USB format application (at least this recognised the drive and allowed me to format).

Also in my searches I found posts regarding removing the VCD. I though I might be the only person who couldn’t se the purpose in this “feature” !!!

I found the link to WD update that gives you the option to disable VCD which I have done.

Thanks anyway