WD My Passport has stopped appearing on my desktop

I am using a Mac Book Air (early generation) and I have a WD 1 TB Passport HD that has worked perfectly for a few years but yesterday, it stopped appearing on my desktop. The WD Smartware icon appears on the desktop but not the HD.

I have tried the following:

Using a different USB cable
Plugging into another computer
Plugging the HD directly into the Mac Book Air

I have checked the disk utilities and it appears there: 999GB My Passport. From here is have Verified the DH and checked for anything to Repair but nothing seemed to work.

I can’t try a different USB port as my old Airbook has only one.

My whole life is on this HD - photos from the past 25 years so I’m keent o try to restore it - can anyone help?


1 Like

I should add that the device powers up, the white light flashes and it quietly hums along as it usually does …

1 Like


It is possible the partition is corrupted. You can try using a data recovery software in order to recover the drive or contact a data recovery company.