WD My Passport 2TB can no longer format as NTFS

This is an odd one.

I originally purchased this drive for external storage on my Synology DS212j. It was successfully formatted with, I believe, EXT3. The My Passport worked perfectly and stored over 1 1/2 TB of data for two months.

The problem began when I decided to re-purpose this drive as a NTFS external drive on my personal computer. I was able to wipe out the EXT3 partition, create a new partition… the first time, I was able to format it as NTFS. Unfortunately, after writing data to it for a while, it began to choke up and actually appeared to lock up File Explorer. I tried to re-format it but I now get a format failure.

But according to Western Digital’s Data LifeGuard Tools, there are no faults found with this 2TB drive. SMART status passes and every test is a success (even the last option, wipe works).

I’m at a loss, I have never encountered a problem like this before.

Can I buy a clue?

Thank you

WD part number: WDBY8L0020BBK-01    0114B

Purchase date: ~ June 2013

Under 100 hours of usage.

It might be important to add that I have tried on both an external USB3 hub and my computer’s internal USB2 port with the same failed result.

If you’re lucky and it’s not a hardware failure, then maybe it’s just a faulty partition table.

If you’re using Windows and you don’t have anything important on the disk right now, try cleaning the MBR and reformatting it using this method:

Open command prompt with Admin privileges (start -> type CMD -> right click -> Run as Administrator).

Enter the following commands, one line after another:

diskpart

list disk

select disk # (For “#” enter whichever number your disk is. Make sure not to select the wrong one!!)

clean
convert gpt
create partition primary
clean
convert mbr
create partition primary
format fs=ntfs label=“New Disk” quick

exit

Then take a look at it in Disk Management (WinKey+R -> diskmgmt.msc -> Enter), assign a drive letter if necessary, and see how it works now.