WD My Passport 0730 500Gb no loonger properly mounted in Windows


#1

Hi,

A friend of mine brought me a My Passport 500 Gb external USB hard drive, because it would no longer be properly mounted on his old W7 32-bit PC and he hoped me to fix tit.

  1. I plugged it to my Linux Mint LMDE 64-bit laptop, and it was instantly detected and mounted. The media did not seem to have any defect.

  2. I connected the WD drive to a Window 7 64-bit desktop PC. Then a specific driver was automatically installed by Windows, and the drive had the exactly same behavior as with my friend’s PC: it was not properly mounted, and the operation of another WD external USB drive which does not use the same driver was also disturbed. I uninstalled the driver, tried several times with the same result.

  3. Then I noticed that the “defective” drive was supposed to create a virtual CD, and probably some executable or data files had been deleted, so that the driver would continually search for them. I installed the driver once more, used the WD tool to de-activate this (useless, to my mind) feature, but I was told it was not activated.

My question (if my hypothesis is true) is: can I force another driver without virtual CD support, or restore the missing files on the disk, or something else ?

Thanks.


#2

Hello Francois_C,

It is recommended to backup the data as the drive is getting mount and accessible on Linux. Then reformat the My Passport drive to check for the same issue.