WD My P Ultraassport

Bought one of these two months ago. Biggest piece of junk I ever came across. The box it came in was about the best part of the deal. Bought an Hitachi 250gb over ten years ago and never had any problem whatsoever with it. It’s been around the world in my backpack. Thrown onto airplanes, thrown onto decks of ships in my backpack and still runs as new. WD? never never never again. Once bitten twice shy as they would say. I couldn’t even be bothered trying to get help with it, In the bin its gone and tomorrow another more expensive Hitachi, but you get what you pay for as they say.

Just to let anyone know. I needed more storage that’s why I bought a WD drive, but now wish I’d paid a bit more and got a decent Hitachi drive.

Hello,

I am sorry you had a bad experience with a WD drive. Can you please specify what the issue is? Maybe it can be resolved and/or the drive can be replaced. Since it is still under warranty.

Hello I bought this from a chap who’d purchased two brand new at a reduced price. He decided after awhile that he did not need 2tb and that 1tb would be more than sufficient for his needs, so he advertised it on a website named Gumtree. He advertised it as brand new, unopened in original packaging, for sale for 30 pounds uk., no offers as he’d paid 52 pounds, 104 pounds for two. I called him, drove to his house and he showed me the item, which still had the seal on the packaging and I could see that it had not been opened, so I purchased it for the 30 pounds he asked for.

I got it home and opened it and connected it to my laptop, which runs windows10 Pro. It worked fine for approximately two months. Then I attached it to a family members laptop to make a backup of her documents and photos because her laptop had a problem with overheating and she was concerned that until she purchased a new laptop she may lose her data, when trying to use her laptop with the overheating problem. Her laptop was an ex., company item and had windows enterprise installed. She obtained the laptop from a previous boyfriend who’d been issued it by his company, as he works in IT.

After they parted company he left the laptop because it was surplus to requirements as his company had changed to Apple products.After sometime later, about 10 months she neeeded to update some software on the laptop for a Sonos wifi speaker system. She could not update it because she did not have the administrator passwords to enable access to update the software, therefore she could not use her wifi sound system. She is an accountant, but only understands the use of computing for her work. I have quite a bit of experience of software and problem solving.

Eventually because we couldn’ t access the laptop to update or install new software, I took it upon myself to install Ubuntu and delete windows. Whilst installing Ubuntu from my WD Passport Ultra, the laptop shut down whilst in the process of installation of Ubuntu. Eventually I managed to install Ubuntu by taking the laptop outside where it was cold enough to allow me to install Ubuntu. A few days later I attempted to transfer her photos back to the laptop and to keep a backup of them on my WD drive. While I was trying to copy to her laptop the copy process stopped after partial copying. I had also a backup of her data on my own laptop in my home.

When I could not proceed with this procedure I abandoned the operation, took my WD drive to my home and connected it to my laptop and had the same problem when I tried to copy some data from the drive to my own computer.

So eventually I decided to format the hard drive, then ran WD’s software that I’d installed on my computer after purchase, ran the WD Drive Utilities, ran the smartware, that passed, then ran the DLGDIAG tests both the quick test and the extended test came back as failed. I ran them twice more and same result, so I gave up, disconnected it from my computer and the next day connected it again to try the test again.

My computer would not recognise the drive and when I tried to get clearance to remove it I got a msg., saying do not remove the drive while it is being used, or words to that effect, so I shutdown my computer and removed it from all power sources then disconnected it. Since then I have tried three times and each time my computer did not show it in My computer as a drive, but as before when I tried to remove it I got the same msg., do not remove the drive while it is being used, close all applications before removing, but there weren’t any applications running as my computer didn’t recognise the drive.

So I’ve resigned myselfcpurchasingca different make of drive and obviously because I bought it from a person who’d previously purchased it from a retailer even though it was in the sealed packaging when I purchased it, plus the fact that I do not have the initial receipt WD., do not have any obligation to myself, so I’ve decided to put it down to a bad experience and purchase a different make of drive.

Thankyou for your interest
John jowett
Sent from Yahoo Mail on Android

Hello again.

You dont need the receipt in order to have this drive replaced.
If the drive still shows under warranty WD will replace it.

Follow this link to verify the Warranty Status of your drive:

if the drive is still under warranty you may contact WD support directly for a replacement or follow the link below for information on how to create a RMA online

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty