Wd My Cloud Windows app not connecting?

Hello Everyone,

I am new to the My cloud device.  Just bought over the weekend.  Very easy to setup and I was working until today.  

My Windows application for WD My Cloud was working throughout the week and now today it won’t attach?  My android phone with the application on it works and I can browse the My Cloud at my house?

Is there an issue with the WD2go.com website talking to my device?



Is this LAN or remote access?

For LAN access File Explorer / Finder is generally a better choice.

Have you set a static IP yet? If not I suggest doing that.

What windows App are you talking about here?

Thanks for the response.

Yes this issue is for remote access.  I can run it when I am at home but not away?  I do have a static IP.

The Windows application is from " http://support.wdc.com/product/download.asp?groupid=904&sid=209&lang=en" 

  • WD My Cloud Desktop for Windows

Also, I can get to my WD my cloud from my android phone when I am away/remote?


I don’t use that but I believe it is for LAN only, there is a WD mycloud app that works remotly

can you get in remotely with the wd2go.com site? this is slower then the mycloud app and has  issues with large files

I am not too sure if you understand what I am using or trying to convay here?

I am using the Software from WD not a 3rd party application.  This is the application that comes with or is used with the WD My cloud drive. Yes, I downloaded it from the WD website.

If there is a better application can you please share it or give me the download to the program that I should be using?

I have been able to get in remotely (with the WD My Cloud application) but it is inconsistant. Just like last week and now this week. 

For example…  I was using the application some last week and sometimes I was able to connect and other times not?  I would say most times not!  I have teamviewer on my home PC and when I cannot connect to “My” My cloud here at work I can still connect to my PC @ home via Teamviewer and get to the My Cloud device on my network?

So, I know the device is on and working.  I should also state that when the Windows application is not working the "Android application is still able to talk to my “My cloud”.

Has anybody had the same experience?

the desktop for windows is a WD app but I believe LAN only and I never user it, use File Explorer instead

the wdmycoud app is generally better for remote access.

when you can’t connect with the windows mycloud app and the android still connects. Is the android using cell data? the same network as the computer? or somthing else?

have you tried the http://wd2go.com site? as I mentioned before the app is generally better but the site can help with debugging and if you really needed to map a drive

I think you are right that the wdmycloud app is better but that is that application I am taking about.  It’s a Windows application that talks to my cloud @ home when I am away.

As for the Windows My Cloud application at work, both my computer and cell phone are on the same network.  1 works and the other doesn’t.

Here is what is interesting though… I tried to get into my “My Cloud”  through the WD My Cloud application and it wouldn’t connect.  I took your advice and connected through http://wd2go.com and connected to my “My Cloud”.  Here is the kicker…  After I connected through the wd2go.com website I can now use my Windows WD My Cloud application.

I am just wondering if there is an issue with the site in general or the http://wd2go.com site talking to my “My Cloud” at home.  Doesn’t the wd2go.com site talk to your registered device on your LAN?

I just think there is an issue with the  http://wd2go.com website and how talks to your registered “My Cloud” device.

The device is very cool but if I have to connect to the wd2go.com site to get the Windows application to work is not a good workaround. 

Thanks for the help.


Did you link your user to a wd my cloud email account? or generate a dac(device activation code) before you leave the house?

The Wd My Cloud Desktop app does work remotely. What you could do it, try to remove the device from your list of previously connected devices and try readding it back. The only 2 ways to add it back is through a wd my cloud email account or a dac.

The desktop app may just need a refresh.


Yes I have linked my “my cloud” device with my current email account. It worked from my work place when I set it up last week but maybe I need a code?  So far I haven’t used a dac because all of the devices we in the house when I set everything up. I sent one to a family member but they haven’t tried to connect yet.  I will try creating a dac for my work computer and try again. 

Maybe I am wrong but why do I need to create a dac when I can connect with my email/username and password in the Windows application?

If creating a dac doesn’t work, I will unlink the device and start over but I thought I have already did this but will try again.

You wouldn’t need to create another dac. A email would work fine.

Have you tried to remove the device and reconnect through email again?