WD My Cloud - Unstable speed transfer


I have tried several fixes and settings (mostly from tips I’ve read on this site) but so far I haven’t been able to get steady speeds on my WD My Cloud.

My issue is that when I transfer files from/to the drive the speed is rather unstable. For example when I stream music most of the times the song will stop at some point while playing.

My set up is:

  • My OS is Windows 8.1, I connect through wifi (130 Mbps) and MyCloud is connected to my PC via a 1GB router
  • My Ethernet cable connecting the WD My Cloud drive to the router is the one provided with the drive and light is green
  • As per some advices in some posts I downgraded to version v03.04.01-230
  • I connect to the WD mycloud with static IP address
  • The UPnP Device Host service on my computer is running

As an example here are two screenshots when copying from the drive using the Windows explorer

  • In this one I was coping a folder with several files:


  • Copying one larger (100 mega) file


Any suggestions on how I can get a more stable connection when transferring and streaming files? Many thanks,

Hi there and welcome to the WD community.

When you see the back of the Unit, What colors are the 2 lights on the lan port ? I would also like to know if you have tested the transfer speed from a different computer to see if you have the same issue.

Hi, thanks for replying ArMak. Both lights are green. 

And yes I have similar behaviour with another computer and devices. For example when streaming with Sonos songs keep on throwing errors half way through…

Try to reset the unit to see if it makes any changes on the transfer speed this is really strange.

Hope this link helps you out with the reset process:


I’ve tried the reset and even a full factory reset but the device keeps behaving in a very unstable way. I have noticed that in the alert section of the dashboard are quite frequent alerts of ‘Network Link down’ (four already since I did the factory reset one day ago).

I have the drive mapped in my Windows 8 and most of the time it shows as disconnected, i.e. with the red cross in the shortcut of the drive within the devices and drive folder…

The device was working fine for the first eight months but since I switched my internet provider and had to reconnect the wd mycloud to the new router it has become extremely unusable. Any other suggestion on how to sort this out?

When you cahnged the router, did you set up a DHCP reservation (static IP address) in the new router and in the dashboard?

 but since I switched my internet provider and had to reconnect the wd mycloud to the new router it has become extremely unusable.

I would be looking at this as the source of your problems, not the MyCloud, which appears to have been working perfectly until you changed router.

So, have you tried a different port on the router?

Have you tried a different router cable?

Are you having trouble accessing the internet with your PC? (This would suggest a problem between PC and router)

Are you having trouble with any other devices connected to ports on your router?

I suspect a bad cable or faulty port on the router.

It’s possible that unplugging the cable from your MyCloud damaged or disturbed its connector.