WD My Cloud - PC Cannot Find Drive on Network (Different than other threads)

Big time WD fan and owner of many of their products. I am also new here, so HI! :smiley:

One of those products is my WD My Cloud and despite some mixed reviews, I love it overall. With the RIGHT router than allows you to transfer at cap speeds, writting and reading is done quickly and efficiently. That is unless I do it on my PC–sometimes. 

See, the problem is I can access the drive on ANY device and stream flawlessly. I can even access the drive on my PC, but after streaming for several minutes, the drive will just lose connection. I have to wait several minutes and it comes back online. I thought this was because the drive was going to sleep, but it disconnects regardless. Even though I am getting the message that it cannot be found on the Network, I know that the drive is still online and active on the network because I will get the error even if someone is streaming off the device in another room. 

Using a tablet or smart phone to access videos and photos is seamless and I never have an issue. The ONLY time I get this frequent disconnect and reconnect is when I stream from my PC. 

Does anyone know of any fixes I can try besides (this is what I’ve tried):

Deactivating sleep mode. 

Changing the drive’s name. 

Updating the firmware. 


I am having the same problem. The share drops out of windows systems randomly, I haven’t been able to find a cause or a fix yet. (And I’ve tried disabling just about everything in the My Cloud controls so far, as well as a static IP)