WD My Cloud / My Book Live mit Dynamischer WAN IP-Adresse

Hallo,

der WD Support hat keine Antwort auf meine Fragen, weshalb ich es hier im Forum versuche, Antworten zu erhalten. Eingangs ist folgendes erwähnt: WD wirbt mit folgendem Satz “Speichern Sie alles an einem Ort und greifen Sie weltweit mit Computern, Tablets und Smartphones darauf zu. Behalten Sie Ihre Inhalte ohne monatliche Gebühren sicher zuhause”. Es geht um die Cloudfunktion der WD My Cloud bzw. der WD My Book Live Geräte. Mit einem mobilen Gerät und den Apps “WD My Cloud” und “WD Photos” kann man von unterwegs aus dem Internet auf die zu Hause stehenden WD NAS-Geräte zugreifen, um Photos auf die My Cloud hoch- oder von ihr herunterzuladen, ebenso mit beliebigen Daten beim App “WD My Cloud”.

Soweit ich inzwischen weiß, wird die Verbindung zwischen dem NAS-Gerät und dem Mobilgerät durch einen WD Server, dem WD2Go Server, vermittelt. Die NAS meldet sich dort an (teilt die Access Codes mit) und ebenso das Mobilgerät (Smartphone oder Tablet). Jetzt kann die Verbindung vom Mobilgerät direkt zur eigenen NAS von unterwegs aus dem Internet aber nur erfolgreich hergestellt werden, wenn das Mobilgerät die öffentliche, externe WAN IP-Adresse meines Internetanschlusses kennt (der Router, z.B. eine FRITZ!Box oder ein SPEEDPORT routet dann an die Endgeräte im Heimnetz). Nun zu meiner Frage: wer teilt dem Mobilgerät die WAN IP-Adresse meines Internetanschlusses und somit die Erreichbarkeit der WD NAS (My Cloud oder My Book Live) mit. Ist es der WD2go Server? Wenn ja, vorher hat er die IP-Adresse? Was passiert, wenn sich diese IP-Adresse immer einmal pro Tag (z.B. um 4 Uhr morgens) ändert? Wer teilt dem WD2go Server oder dem Mobilgerät für die Verbindung mit der Home NAS dann die geänderte IP-Adresse mit?

Gruß

hfrsamba

Hi,

“…wer teilt dem Mobilgerät die WAN IP-Adresse meines Internetanschlusses und somit die Erreichbarkeit der WD NAS (My Cloud oder My Book Live) mit. Ist es der WD2go Server?..”

siehe Stichwort:  Dynamische DNS

https://de.wikipedia.org/wiki/DynDNS

WD bietet mit Wd2go einen dynamischen DNS Service an.

Gruß

Lucky:wink:

Danke, habe es nicht erwähnt - DynDNS -, aber ich kenne dies bereits von meiner FRITZ!Box und meinem Iomega Netzspeichergerät. Bei den WD NAS-Geräten kann man aber nirgends DynDNS einrichten, was notwendig wäre, wenn es der Router nicht tut. Mein Router aktualisiert aber nicht den DynDNS Namen, den der WD2go Server benutzt, sondern den Service von Dyn.com. Bleibt immer noch die Frage offen, wer informiert den WD2go Server von der geänderten IP-Adresse? Bei mir ist es nämlich so, dass die Erreichbarkeit der WD NAS-Geräte bei manuellen Netzwerkoptionen mit eigener Festlegung der Portweiterleitung (Port 80 auf 8080, Port 443 auf 8443) für die WD NAS-Geräte nur 24 h funktioniert bzw. nur solange bis mein Provider mir eine neue IP-Adresse zugeteilt hat. Ich vermute jetzt, dass nach Zuteilung einer neuen IP-Adresse der WD2go Server immer noch bei Anfragen von den Mobilgeräten die “alte” IP-Adresse vor der letzten Änderung verwendet und somit die Apps auf den Mobilgeräten keine Verbindung zu den WD NAS-Geräten herstellen können. Entweder der DynDNS Update Dienst funktioniert nicht richtig oder die Apps haben ein Problem. Wenn die Netzwerkoptionen automatisch konfiguriert sind, also Port 80 und 443 verwendet werden, klappt alles einwandfrei. Mein Routerhersteller hat das Szenario untersucht und konnte kein Fehlerverhalten am Router feststellen. Wo liegt also das Problem?

Abhilfe für das Problem bei manuellen Netzwerkoptionen ist derzeit nur die Neustart des WD NAS-Gerätes oder im Dashboard einmal Remote-Zugriff aus- und wieder einschalten. Danach - mit 15 Minuten Wartezeit - können die Mobilgeärte wieder die WD NAS Geräte erreichen. Ist aber von unterwegs nicht möglich, sondern nur von zu Hause (oder man richtet sich ein VPN ein, muss aber dann dennoch jeden Tag am Dashboard der WD NAS sitzen)

Vielleicht noch wichtig: der Router über den die Mobilgeräte per WLAN ins Internet gehen, hat DynDNS=Off und DHCP LeaseTime=1 Tag. Der Router an dem die WD-NAS Geräte per LAN angeschlossen sind, verwendet DynDNS mit TZO und die LeaseTime dessen DHCP ist auch 1 Tag genau wie die LeaseTime des WAN Routers meines Internetproviders=1 Tag. Mein Heimnetz Router aktualisiert den Hostnamen (den die WD NAS-Geräte aber nicht verwenden) per DynDNS Update alle 15 Minuten.

Das Problem konnte gelöst werden, fast unglaublich, aber mit der telefonischen Supporthotline von WD. Ich musste nur alle Netzspeichergeräte mit statischer IP-Adresse auf DHCP umstellen, und schon wird sofort mit Änderung der WAN-IP-Adresse an meinem Internetanschluss auch eine Konfigurationsdatei in den Netzspeichergeräten mit dieser geänderten IP-Adresse beschrieben und dann auch an den WD2Go Server übermittelt, sodaß der Zugriff von Mobilgeräten auf die WD My Cloud Geräte sofort wieder klappt.

Fazit: in den Einstellungen -> Netzwerk -> Netzwerkdienste -> Netzwerkmodus nicht auf STATISCH stellen, sondern auf DHCP, dann aktualisiert der DHCP-Server des Routers auch die Geräte bzgl. einer geänderten WAN IP-Adresse. Fährt man mit der Maus im Dashboard über das Ausrufezeichen, erhält man sogar den Hinweis “…Wählen Sie DHCP, …damit Konfigurationsinformationen über das Netzwerk abgerufen werden”.

Meine Frage nach dem Updatezyklus dieser WAN-IP-Adressenänderung, wußte eine Spezialist nur eine Antwort: “dann, wenn es der DCHP Server macht”. Aber es hat jetzt ein halbes Jahr gedauert, bis diese Antwort aufkam und zur Lösung führte.

Grüße

hfrsamba

Es sollte auch möglich sein Zugriff zu erlangen wenn das NAS eine statische IP-Adresse hat. Wurde denn in den 6 Monaten nie ein Reset empfohlen? Das hätte nämlich dazu geführt das die IP-Annahme wieder Dynamisch eingestellt wäre.

Ein Reset wurde nie empfohlen. Ich hätte auch die meiste Zeit in den 6 Monaten die Netzwerkoptionen auf automatisch, d.h. keine manuelle Portweiterleitung, gestellt, womit es auch mit statischer IP-Adresse funktionierte. Nur bei manueller Portweiterleitung ohne UPnP im Router war Remote-Zugriff bei gleichzeitig statischer IP-Adresse der WD NAS-Geräte und dynamischer WAN IP-Adresse am Router nur bis zur Zwangstrennung oder manueller Trennung des Internets im Router mit Zuteilung einer neuen WAN IP-Adresse möglich. Danach musste entweder das WD NAS-Gerät neu gestartet werden oder im Dashboard der Remote-Zugriff einmal aus- und wieder eingeschaltet werden, damit in einer Konfigurationsdatei der WD My Cloud wieder die aktuelle WAN IP-Adresse steht und somit an den WD2Go Server übermittelt wurde. Anscheinend werden Geräte mit statischen IP-Adressen, die außerhalb des DHCP Adressbereichs des Routers liegen, nicht vom DHCP Server über eine Änderung der WAN IP-Adresse informiert, eventuell zusätzlich wenn eine manuelle (Port 80 auf 8080 und Port 443 auf 8443) Portweiterleitungsregel verwendet wird.

Beobachten konnte ich es gut im Fall statische IP des WD Gerätes und kurzzeitiges manuelles Trennen des Internets mit Hilfe der Router Weboberfläche: Remote Zugriff funktionierte nur solange in der /var/www/rest-api/config/dynamicconfig.ini Datei die aktuelle externe IP steht. Bei statischen IP im WD Gerät und Neuzuteilung der WAN IP durch den Provider DHCP (alle 24 Stunden oder manuell erzwungen) wurde die externe IP in dieser Datei nicht aktualisiert,  zumindest nicht innerhalb von 30 Minuten (vermutlich gar nicht), sondern erst dann, dann aber sofort, wenn die WD Geräte auch eine dynamische IP meines Heimrouters aus dem Adressbereich dessen DHCP Servers erhalten haben (diese kann dann auch DHCP statisch sein, wenn man den Router so einstellt, dass das WD Gerät immer dieselbe IP-Adresse von Router DHCP erhalten soll. Wird dann im WD Gerät aber nicht als statisch konfiguriert, sondern als DHCP).

Quintessenz: statische IP-Adresse im WD-Gerät mit Dynamischer WAN IP-Adresse ist eine falsche Empfehlung und fehlerhafte Konfiguration!

P.S. Habe nochmals alle Kombinationen durchgespielt. Mein Fazit diesmal: alles Müll, was WD da fabriziert hat, erreiche jetzt mit den Einstellungen, die eigentlich bisher immer funktioniert haben, von 3 Geräten nur noch 2. Habe keine Lust mehr, konzentriere mich auf meine Eigenbau NAS, damit funktioniert alles.

P.S.P.S. Mußte eine Stunde warten, bis wieder alle 3 WD Geräte remote mit dem Smartphone bzw. Tablet erreichbar waren