WD My Cloud - I give up! Product is not ready for sale!

I tried a lot of things during the last weeks. But with the latest firmware the my cloud is not to use!
I don’t have remote Access to the device. I tried following:

  • Update to latest firmware
  • disable and enable remote access
  • static ip address at my cloud and the router
  • portforwarding for the static ip for the ports 80 and 443
  • reboot the device
  • unplugged the device
  • enabled Upnp

In my home network i have access to the NAS. I have just a 100 megabit router and i know, the transfer rate is slow. But i don’t have access with my Nexus 4 (Android 4.4.2) and my iPad4!
Today i gave it the last try. After reboot i had access with my Nexus. After 30 minutes i didn’t have it. I tried it with mobile network. In my local network i have access with Nexus and iPad. But after some time, it seems that something change and the device is not accessable.

I don’t know what is the error. I will sell it and will buy another NAS from another Brand!

Which external port did you forward to the port 80 of the NAS?

Some ISP block access to port 80, so you might have to forward a port like 9080 or 8080, …

What does the connection status of the cloud access under settings general say?


It says, that mycloud has Internet access.
The first minutes I have remote access, too. But after a short while I haven’t access. But I didn’t change the settings. So I don’t think it’s something with my ISP.

On the ipad, remove the device from the app (there is a +/- sign on the top right. Then add the device again.

Below “connected”, what does it say? Relay connection or port fowarding established?