WD My Cloud Gen 2 Purple Led

Hi all,

When trying to force entering recovery mode, because I wanted to downgrade from Cloud OS 5 to 3, I did a mistake running the command via ssh:

dd if=/dev/zero of=/dev/mtdblock0

When WD My Cloud restarted it directly gave solid purple led (not red, not blue). There is no blinking leds back on the Ethernet.

I tried the 4 secs and 40 secs reset with no luck.

I tried to boot via USB (WD Recovery) with no luck either.

I disassembled the cloud and was able to get all the data from the drive by hooking it to Windows PC and using ext4 partition reader.

I don’t know what the problem is, I am guessing the problem is more likely to be on the board and not on the HD drive.

Help is pretty much appreciated.


User Fox_Exe has unbricking directions for both first gen and second gen single bay My Cloud units. See the following for the second gen v2.x single bay My Cloud directions.

Second gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
usbrecovery.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/usbrecovery.tar.gz
Alternate method files:
uImage-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery
Latest second gen firmware: http://support.wdc.com/downloads.aspx?g=904

Thanks Bennor for your reply,

I already tried this. Got a USB Stick (FAT32) added the boot folder and insert it to try to boot from it with no luck.

I also kept it for hours since there was activity on the hard drive but the led stayed solid violet, and no activity on the ethernet cable.

There are two different directions in those unbricking links. One uses Telnet and a USB flash drive. The other method involves extracting the second gen single bay My Cloud hard drive, attaching it to a computer using a USB to SATA adapter (or similar connection). Then using Linux to perform the various steps.

Note: The parted and mkpart steps are partitioning the hard drive properly for the structure used by the My Cloud OS3 firmware. One (assuming they haven’t corrupted one of the existing partitions) can bypass those steps and the mkswap and mkfs.ext4 steps if one want to try and keep the user data intact on the hard drive.

Thanks again for your time,

I tried the alternative way (didn’t notice it before).

Unfortunately, it didn’t work either. The only way now to know what is happening on the board is through serial connection which I don’t have the tools or knowledge of. So, I decided to give up on this and ordered a diskless WMC Ex2 Ultra.

Updating to Cloud OS 5 before reading feedback was a mistake. This indexing thing they implemented nearly fried my system and now it is dead. Good thing the drive is still alive.