WD My Cloud FTP issue

Hello

I am trying to reach a My Cloud 2TB from another computer on the same network.
However, I can only log in over FTP with two users from the five I have defined on my drive. The user I want to log in as just gets “Error 530 Permission denied”.

Is there a setting I can change to fix this from the web interface?

Thanks in advance. :slight_smile:

Hello chris667, review the steps from the following link. 

How to access data on a WD Personal Cloud drive and other WD NAS devices, using FTP 

No dice, as my friend above puts so well.

There is no option to increase the maximum number of FTP users on a WD My Cloud through the web interface.

Depending on the FTP software the router uses, I imagine I could enable ssh to log into the unit and increase the number of allowed FTP users. But I’m hesitant to do that, as it is a new unit and I don’t want to invalidate the warranty.

chris667 wrote:

No dice, as my friend above puts so well.

 

There is no option to increase the maximum number of FTP users on a WD My Cloud through the web interface.

 

Depending on the FTP software the router uses, I imagine I could enable ssh to log into the unit and increase the number of allowed FTP users. But I’m hesitant to do that, as it is a new unit and I don’t want to invalidate the warranty.

If you browse this forum you will find a huge number of firmware bugs reported.

Imho you better consider returning it for a full refund. Otherwise you will spend a lot of time and most probably still not get a satisfactory solution?

Yes, it does have lot of bugs. But then the chances are anything else I buy will have bugs too.

And to be fair, I am trying to use this device in a way the developers didn’t expect me to use it.

So it will stay if they can find me a solution.

sorry for disturb, can you tell me what is the ftp adresse for My Cloud 2tb please?

the adress of the FTP is your drive ip address. if You are using DHCP change it to static and reboot.

Forgot to add. If you are using it remotely, you need to forward the FTP port on your router, and enable FTP on your mycloud; in this case the FTP IP address is the IP address of the ISP.

For example: I have mycloud on 192.168.1.200, ftp enabled

My router forwarrd the FTP port,

My ISP (or router internet address, not local -> not 192,.168.,1.1) is 88,168,6,. 223. In this case I give the application this ip address for the ftp. Now I can ftp locallly and remotely without changing anything. I use it on Ipad at work  to access work document on my mycloud.

Sure, no SFTP yet,but I beleive it is coming. Plain old FTP for now if you must. I don’t know why anyone wants to use FTP. I only use it when I am on local network to transfer docs between an Ipad app and my drive. Sure I cna send it to DropBox and get it back to mycloud safely.

CountDooku125 wrote: Pretty high risk because the Linux kernel of MyCloud did not get all security upgrades!! > * * *

QNAP NASes still use 2.6.33.2.   QNAP updates firmware frequently.

My Cloud uses kernel 3.2.26 which is much newer.

Are you also telling everyone here that QNAP is much more risky because kernel is much older?

Yes, google is very good at finding support of my statement:

https://www.kernel.org/doc/Documentation/applying-patches.txt

Kernel Patches are *ALWAYS* reflected in Linux Version numbers.

So says the Kernel maintainers and GPL.

"

What is a patch?
---
 A patch is a small text document containing a delta of changes between two
different versions of a source tree. Patches are created with the `diff'
program.
To correctly apply a patch you need to know what base it was generated from
and what new version the patch will change the source tree into.

Oh I realize that Mr. Count_Dooku’s eroneous claim was deleted.

He had originally said that you cannot tell by version number which patches are applied to a kernel.

That is so very wrong.

I had the same problem and it seems like I solved it. I’m not sure if this will work for you as well but try.

I was not able to log in with any users including my own with “530 Permission” error. I was fiddling with my router, pc, with no avail.

Solution was simple enough. I turned off the FTP service and turned it on again on the dashboard. Walla~, it works!

The problem with me was that, I have changed my user name just after I turned on the FTP service. So no users were recognized.

I hope WD fix this dumb problem soon.