WD My cloud extremely slow

Hi,

For unknown reasson my transfer speed to WD My cloud has become extremely slow.

Copying a ISO file gives approc 700KB. I’m using Windows 8.1

I have tried to fall back to previous firmware version but same result. No running on v04.00.01-623.

Only when i change the setting for Jumbo frames to 9kB MTU the speed changes to an acceptable speed of 60-70MB.

However in another post I found it being not wise to do so as it could result in communication problems with other devices.

I performed a factory reset system only. No result.

Contacted the support team from WD and they advised to make a direct connect using static IP addresses. No result

I have changes all cables to eliminate broken or bad cables.

Any suggestions, as I’m considering to throw the device in the garbage. :frowning:

best regards and greeting from the Netherlands,

Just

How are you copying the files?

Is this on your local LAN? or remote?

what are the LEDs by the ethernet cable doing?

what FW are you on? Not sure if “No” should be now or not

Hi Larry,

It is on a local wired LAN running at 1 Gbps. I checked the adpter speed which is autonegotiating and which is at 1 Gbps.

Light at WD mycloud is green.

As stated I tried a direct connection PC --> WD mycloud with static IP adresses.

I’m copying using the Windows explorer drag to…

With Jumboframes set at 9K MTU it is running fine, but not advisable.

thanks,

Just

what FW version are you on?

what other types of files have you copied up & approximate size?

Hi Larry,

FW is v04.00.01-623 but I also tried to fallback on previous version.

It is observed with both ISO file from 7 GB as smaller files like MP3’s

Hi,

I think I solved the issue. In another post I found that the UPnP Device Host service should be started. It was off.

No I can transfer at speeds of approx. 60 - 82 MB/s.

I do not know why it was set to off…

thanks anyway,

Just

I do not know how to turn on “UPnP Device Host”. Is there a simple user level action that I can take to improve the painfully slow file transfer from my windows laptop hard drive through the LAN to the router, and the LAN gbe port to the WD MyCloud? Current speed shows more than a day for 400 GB of video data! Unacceptable.

Hi,

Press the Windows+R keys to open the Run dialog, type services.msc , press Enter.

Scroll to UPnP Device Host / Right click and select properties. Then select to start the service automatically.

I am not real familier with the UPnP services but I suspect this was only an issue because you were direct PC to mycloud.

I suspect it you either have a router with this enabled or set the mycloud to manual port forwarding it would not be an issue. the mycloud was probably continually searching for this