Wd My Cloud disconnects/crashes after a "powered USB hub" is connected with external hard disks

Hello guys,

I just found a big bug.

I have Wd My Clud 4T fully working attached to the network.

I configured a powered USB 2.0 hub with 7 slot ports that I connected to the USB port of my white WD My Cloud; I attached 3 Hard Disks to this hub.

When I connect the hub My Cloud starts analysing it, it recognized 3 Hard Disks on 4 and after some minutes it does not reply anymore to web interface (disconnected? crashed?).

Please advise how to fix this issue.



Hi maxthebest, have you verified if the problem happens if you connect the USB Hub and then each hard drive individually? This way you can be sure that the problem is not caused by one of the connected hard drives. 

Thank you for the answer.

Yes, I made these tests:

  • I attached 1 hard disk and it worked fine only with 1 external Hard disk

  • With powered USB Hub we have 2 behaviors:

   - “No USB devices found.” like now (only 2 hard disks connected to the powered USB Hub)

   - 3 hard disks on 4 found but after it disconnects or crashes during the analysis

If I attach the same Hard Disks in a Windows 8 computer they work very well and fast.


Hi again, can you share the model number for the USB hub you are using? The problem could be related to that specific model. 

I spent 40 euro invane!

I tried 2 usb hubs:

  1. HAMLET EXAGERATE HUB POWERED - USB 3.0 http://www.hamletcom.com/products/xusb340hp.aspx


in both cases only a single hard disk is recognized. If I put them in windows 8 no problems AT ALL.

I’m having the same problem when I plug in a 1tb WD external drive.