WD my cloud - connectivity issues after win10 update


I have connectivity issues with my WD my cloud mirror 4TB after a regular windows 10 update - I previously had win10 installed in this computer and there were no problems. I have read many threads in the forum but I have not been able to see this exact issue.

Summary of the issue:

  • When I try to access WD my cloud through windows explorer it shows that credentials entered are wrong

  • When I try to access WD my cloud through my web browser using the static IP address asigned to the devided, it displays a message saying that website cannot be accessed

  • When I try to access WD my cloud through the official app, it shows a message stating that device could not be found

  • This problem only happens in my main computer. I can still access WD my cloud from other laptops either using win explorer, web browser or the app.

Things I have tried and have not worked so far:

  • Change my WDmycloud user and credentials (using another laptop)

  • Delete network connection (Net Use * /delete)

  • Delete WD credentials using windows credentials manager and rebooting

  • Use RegEdit (1. Create a Dword called ‘AllowInsecureGuestAuth’ in HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorks, 2. Set the new value to 1, 3. Then close Regedit and Reboot.)

Any suggestions are very welcommed :slight_smile:

Many thanks,

Hi, I have not idea why this might be happening and you already did what I would’ve done, hopefully another user will be able to provide some information, you can also contact support and see if they have any information.