WD My Book Studio Edition II 2 TB NTFS File system damaged & sets to RAW "Help to save my Data"

Hello WD  Support,

Please I’d appreciate for your help about my WD My Book Studio Edition II 2 TB So,

I tried once more a time to start it again So I can see the partition in my computer after a long load time but the same the partition was asks for format and I don’t and now not asking and the drive seems to be no data inside and no file system and can’t detect the HDD spaces only if I’m in Disk management and it’s said healthy OK but no file system ?

Note : As you know, the indicator bright in the foreground looks like the letter I become light in the form of flash from the highest index to bottom except the center on the continuation thereof and useless left with a lot of time hoping to work again. So is there any difference

 and the partition found in my computer but it’s like RAW without file system & Healthy in disk managment, WD Drive manager and When try to use Raid manager it’s said Device not found .

All that happened in my sleeping time and When  waked up find that problem So don’t know what’s happened But I’m sure u will know more than me. much appreciated

Waiting on a Fire for your Reply

Thanks in advance & Best Regards,

This one is kind of difficult. However, download Recuva or Photorec perhaps you will be able to recover some information with this application is free.

I tried them all and nothing happened So all I need to recovery the NTFS file system to my Device So is there any way ?

You can try TestDisk http://www.cgsecurity.org/wiki/TestDisk  Sometimes using the MS method to convert from FAT32 to NTFS fixes it  http://support.microsoft.com/kb/214579 It apparently rebuilds the partition data.


Guys any programs cant detect the size of disk or any info only the name WD my book and the size 0 kb and only detect after the long time loading the device in Disk management Only with the capacity size and the partition icon visible in my computer but I can’t format or do anything to access the Device So any help if I take them out and connect them inside the PC with sata cables would be ok or no ? I can’t fix the device with any softwares on internet I used them all who’s showed in Google but no news still no access So any help to format ? or must take them out and connect them inside PC with Sata cables ?

Wating for reply

Thanks in advance & Best Regards,