WD My BOOK Live 3TB woes

Howdy All,

Pikced one up yesterday and had nothing but issues so far,

Wouldnt pick up the device, had to set up an ip for the MAC address on router to get it a standard every other device picks it up from the dhcp server

Couldnt connect to UI/extremely slow connecting anything from 5mins - 20 mins to actually load the basic web ui.
 while this happened took a look at ping times etc mostly shows 1ms with a few request time outs and spikes

after loading ran update to see if it would fix… but did not, scoured these forums for solutions tried direct connection didn’t change a thing, trieddifferent cat 5 cable still nothing, spent ages trying to get SSH enabled and finally did tried to run the factory reset from there & reboot which went through but changed nothing.

also tried it on mobile devices and other computers with same results

Tried netstat and got this:

                           Received            Sent

Bytes                     308137968       249057017
Unicast packets             1437924         1954710
Non-unicast packets           39706           37473
Discards                          0               0
Errors                            0              21
Unknown protocols                 0

SSH shows the following for eth0

MyBookLive:~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:90:a9:bc:c7:f4
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::290:a9ff:febc:c7f4/64 Scope:Link
          RX packets:7021 errors:1720 dropped:1720 overruns:0 frame:7040
          TX packets:4276 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:570517 (557.1 KiB)  TX bytes:2518544 (2.4 MiB)

both show some sort of errors/dropped packets which i suspected from the start…

So have i got a dud? anyone suggest any fixes?, i did manage to get some data moved onto the drive although at about 230KB/s before it just randomly disconnected its self

I would really be appreciative of any advice you guys have

Edit: I also noticed that some threads talked about the setup pages when using the UI for the first time… i never seem to get this nor do i require a password to login even if admin password is changed

Try updating the firmware to the latest version. Check the link below for the steps. 


Aye, Allready managed to do that earlier on in the day but did not help. got myself a replacement today and it works better web ui is accessible less packet drops but issue is sitll there… main issue for me with this new one is that i can put files on it at decent speed but if i try to view or copy from the drive it’s somewhere between a few bytes to 5KB/s then connection resets.

Currently trying a Full Factory reset see if that helps.

Restore fully completed… still cant really read things off the device effectively even if direct connection is made… max ive gotten is 15KB/s read

You have TONS of errors.  Check your cabling.

I suspect its a Router issue, cant seem to find anything out of the ordinary tried forwarding the SMB port but did not help im guessing its to do with packet fragmentation cant seem to find any options to stop blocking them. i’ve tried to disable the UDP Flood and TCP SYN-Flood options dont seem to help.

After factory reset i can read at about 60-70MB/s with direct connection ruling out my computers firewall also noticed that there were no dropped packets across direct connection any suggestions on what i can do with router? currently using a Netgear DGN2000 i do have another router but thats wireless G & also netgear running similar firmware…

Any help would be appreciated~


You are tilting at windmills with all of that.  When you are on your local network, none of those options are even relevant.  And SMB port forwarding is a huge security risk.  TURN IT OFF.

Did you do what I suggested and check your cabling?  Also try using different LAN ports on your router.

Aye, it was only turned on to look for changes even though it shouldnt matter ^^;

As for physical cables ive swapped them around and no change i do seem to have 1 duff port on the router that wont have a DHCP address issued to it for some reason… so cables are fine :slight_smile: