WD My Book Essentials 1TB USB 3.0 Broken

Hi Everyone,

I’ve been desperately scanning for a solution for my problem and I can’t seem to find a thread that has come up with anything I can work with. I have been happily using my external hard drive for over a year now and there have never been any problems with it whatsoever, until today.

Here is the current state of my hard drive:

  1. Turns on with only the power connected. (USB port connection not anymore necessary)

  2. LED Light turns on and stays on.

  3. I can hear the HDD drive inside moving but after 10-15 seconds it just stops.

  4. Can’t be detected by any device. Nothings happens when I connect the hard drive to devices I used to connect it to. (Laptop/PC/TV)

That being said, here are the series of events that led me to realize that I have a problem with my external drive:

  1. Went to sleep last night with a video stored on my external drive playing on my laptop. The drive worked without a hitch. The drive was detected and was able to play the video file just like any other day.

  2. Woke up this morning and decided I’d finish the video I was watching before fell asleep, realized that for some reason the drive was not anymore detected by my computer.

  3. I figured that it must be some kind of connection problem that got loose during the night, but after checking all connections the drive was still not detected by my computer.

  4. Through the process of checking all my wires, I realized that for some reason the drive turns on even though it is only connected to the power. It used to be that it would only turn on if I connect it to both the power and the usb port.

Tried the following things with no luck:

  1. Used a different power cable with the same 12V and 1.5A ratings.

  2. Used a different usb cable from my other WD HDD.

  3. Used different usb ports. (all three ports from two different laptops, one of which is a 3.0 usb port and another USB port from my flatscreen)

  4. A process that was said to “reset” the board of the My Book (involves taking out all the wires. plugging in the usb port first in a pc that is off. turning on the pc. then finally plugging in the power of the my book)

Really hoping someone here can help me as I desperately need this drive to work again ASAP. Thanks in advance to any help that is offered! 

Just to add, when I push the power button at the back the drive starts up again and stops after a while (just as if I had just inserted the power cable into it). If I hold the power button, the LED light starts blinking slowly, as if it were in standby mode.

Hi There…

Couple of weeks ago the same thing happened to my WD passport external drive. It has a lot of information stored but wasnt full. I never use it! However on this occassion I went to access it and it opened fine and then my laptop froze so I restarted and thats when I got a message saying that the disk needed to be reformatted! Huh?

The LED lights up and all the bells and whistles and sounds etc occur.

Its frustrating. These drives are designed to back up information! Now we have to back up the back up!

If someone answers you with a resolution please let me know!



I have the same exact issue.  I have never noticed whether the little lock light came on all the time or not but it is on now.  Same issue started turning on with just the power cable connected lights flash when I press the back button, where as before my **bleep** back button didn’t even work when I first got the thing.  Now it sits there and it’s the only place I have all the pictures of my daughter because my computer crashed.  everything from 2006 on up until today…I’m so pissed off if the important stuff wasn’t there I would just crush the **bleep** thing with a hammer…But if the important stuff weren’t there I would just re-format it.  I’m going to try to get ahold of customer service or something doubting I’ll have any luck.  Please let me know if either of you get yours running.  I just want it on long enough to back everything up to my computer and I’ll back it up to My Yahoo from there.

I am also experiencing a device failure. How come all the sudden our drives are dropping dead like there’s a plague. I have tried many recovery method without any success. I also have all my photos since 2004 till now and also not to mention some other files I backup. :cry: