WD My Book Essential 2TB - Freezes my Samsung Smart TV while loading?

Okay, so… After hours upon hours of browsing through similar posts on multiple sites I have not been able to find anyone with the EXACT problem I’ve recently been experiencing, so I thought I’d give this a go and hope someone has some ideas which may help me!!

I purchased my WD My Book 2TB around June 2011.

I didn’t know anything about them at all so wasn’t aware that it is designed for backing up your computer/laptop (Correct me if I’m wrong, not too sure) Anyway, I’ve always had movies, TV series, music etc, containing multiple video formats stored on my harddrive. Which I then connect to my Samsung Smart TV via USB and have been able to watch and listen to all files without a problem… Until now. 

Everything was working perfectly then one day I turned my TV on (HDD already connected) it will power on, light flashes, inside buzzing/whirring noises etc, light will stop flashing and stay on. Prompt comes up on my TV saying new device connected and the option to open, which I do.

Harrdrive media menu comes up, top right ‘loading’ with the circle rotating in the corner for about 30-60 seconds then all of a sudden… TV turns off then back on, making the harddrive do the same. Then the same thing happens again. During the ‘loading’ time, my TV has frozen. I’m not sure if it’s my harddrive causing this or my TV but I have been using the 2 together for approx 18 months without a single problem and have no idea why its all of a sudden randomly started.

I’ve removed everything off my harddrive - thinking there may have been too many files - not the case.

I’ve wiped & reformatted to NTFS then to FAT32 - nothing has worked.

Downloaded & installed the latest firmware - still nothing.

Each time I try something different I will copy a couple video files in assorted formats to the harddrive then plug into the TV and it will be the same process mentioned above.

I have no problems with it while plugged into my laptop, can copy on & off of my drive, and play the files with no hesitation - although sometimes the harddrive does disconnect and reconnect straight away - not very often but it’s also a new occurrence.

Not sure if anyone can help me, or even be bothered to read this massive long problem post - if you can then THANKYOU in advance.

Please help - I’m out of ideas. An RMA might be my last resort…


Have you try connecting the drive to another TV or perhaps using a different USB cable?

Maybe writing zeroes to the drive could work, try using the Western Digital DLG application.


Thanks for your reply.

Well no, I haven’t tried another TV as I only have the 1 at home. Don’t know why I havent aready thought of that. I will try connect it to someone elses TV when I can and see what happens. Haven’t tried another cord either, for the same reason, only have the 1. Not sure what writing zeroes entails or what it actually does… I’ll search it and have a look… 

Thankyou again for your suggestions.