WD My Book Essential 1110, 2tb USB 2.0 is SO SLOW

Hey…I need help people.

My WD My Book Essential 1110, 2tb USB 2.0 was working fine until just the other day when it started running SO SLOW.

I can’t write or read data on the thing. I can’t hardly get access to the SmartWare drive. When I do it fails every test. It was working fine one second and then froze like crazy.

What was I doing? I was reading a CBR file from the drive. My kid was on my lap and he hit the keyboard and it tried to open several files at once. After struggling to close out the program, it has run slow can be ever since.

For example, it took me probably 45 seconds to delete a 43 byte text file. I can’t even imagine what it would be like if I tried to pull data off this thing onto another drive. It also takes FOREVER for explorer to browse a directory, no matter the size. I can’t stream any media from it.

What the heck is going on with this thing?

It fails all the diagnostic tests on the SmartWare software. Drivers are current. Device manager says its fine.


I’m running a year old HP, Windows 7, 64. Tell me what the deal is, please.

You should test the drive with HD Sentinel or other software

not sure why you won’t be able to stream file or if it has something to do with the drive itself

Try running a test with DLG, if the test completes successfully you might have a data corruption problem, in that case backup all the files you can and then format it. If the test fails, replace it.