WD My Book Duo data forever lost if Drive Enclosure Dies!

Does problems like this also affect the “My Book Pro” series?

yes, thats my understanding as well… Once you encrypt your WD harddrive its fully encrypted and if the hard drive or its enclosure fail then your harddrive is stuck in a locked state forever… but I still dont entirely understand how a harddrive enclosure failing means the whole harddrive cant be used again? like why cant you just swap your working harddrive into a new enclosure?? on a sidenote i didnt even know enclosures on their own can fail…

The enclosure holds the little piece of computer code that runs the mirroring and small amount of software that you can access on the drive. (e.g. the web gui).
The linked piece tells you that the enclosure holds a master key which has encrypted the drives. The drives are permanently encrypted regardless of whether you have told the drives to be or not. All you are doing when you set a master password and “tell” the drives to be encrypted is you are encrypting the master key - thereby ensuring that no one can hack the drive enclosure and retrieve the key and then decrypt the drives. Therefore, the drives are always encrypted and if there is a failure with the enclosure then you need to find out a way to get that key and somehow use that master key to decrypt the drives.

I am so happy that I stumbled across this article while looking for something entirely different ! I shall be dumping my HD book duo immediately (after having carefully taken everything off and put it somewhere that I know I can get into regardless of enclosure hardware failure !!). Well done @jtech !

i am pretty sure wdc externals use soem kind of encryption, and it is on the board from usb to sata, i tested it myself with a wdc my book 4tb, i trowed up som random stuff, then connected it direcly to pc and hdd was empty, wdc hides something reguarding this shitty protection , they dont want users to save their data

Is there any news on this topic? It seems as if is a big Topic for many users.

I am currently struggeling with a very similar problem. I disassembled a MyBook 4TB to put it into my PC housing (wanted to get rid of the case on my desk) and no data was shown. Windows asked me to initialize the HDD and I did so. Now it seems my data is neither visible in my PC nor if I mount it back into the WD case :-o (Drive doesn’t show in the explorer)

Did anyone manage to gain Access again to their data ?

greetings

Thanks for the informative posts. I was looking for a couple of good quality external USB drives to expand a couple of MyCloud drives via the USB port. My older WD 2TB Elements drives have always worked well, sleep when not in use, etc., so I thought a new 4, 6, or 8TB WD MyBook would be a good choice.

Note to WD, if they ever monitor these forums: CHOICE is good. If I want an encrypted drive that can never be read by any other hardware, so be it, but I do not. If the box fails, I want to be able to connect SATA power and data cables to the bare drive, or put it in a generic or other box, and be able to access the data just as if it were in the original WD drive.

The idea of a backup is to provide the most security from data loss, not to prevent a user from using your drive in another housing. Simply letting the end user choose settings which saves data in an unencrypted, Windows-readable format would be great, but instead you handicap your equipment with this ridiculous “feature” that makes any backup capabilities of this drive worthless if the housing fails.

I won’t be buying any more of your external drives because of this. Glad I found out ahead of time.

1 Like

That’s not the point, which is the way WD has applied the encryption without providing the customer the means to recover his/her data. Windows allows the user to encrypt data but it is an optional feature. Forcing encryption with no means of recovery, as WD does, is very poorly thought out.

You might hang onto the drives. You could reformat them and use them as normal drives, could you not?

You can but you can’t recover the data. You’d have to reformat, losing all your data.

Is this really still relevant today ? Does the My Book duo 16TB (WDBLWE0160JCH-EESN) really still encrypt all the data in RAID1, without the user explicitly enabling encryption ? Encryption can not be turned off ? There was never a firmware update to fix this ?

I’ve seen that there are two manuals in the download sections. One is marked with “Unser manual (PDF)(unencrypted drives)”. Unfortunatelly I didn’t notice any difference between the manuals that we explicitly state, that enryption is/can be disabled on certain models of this disk. Also, there are just different sizes of the My Book duo listed, there are no models listed with any indication that they have disabled encryption for good.

I’m on the edge of purchasing such a drive (I have actually already ordered). But if I still (2017) can’t take out one of the drives (in RAID1 mode, no encryption) and read it in a standard computer. I will have to cancel my order immediatelly. I want to use this drive for nearly real time backup of my many other drives. I do have a tape solution for archiving, and general backup. Still, if I can’t read disks from the My book duo, in a standard computer, this is a deal breaker and I will have to cancel my order immediately.

I think it is clear, that most RAID1 users, don’t expect such a “feature”. Please WD give an explanation why this should be a good thing for anyone not wishing to work with encrypted data. Maybe we can start to understand.

That is exactly why I would NOT touch any WD hard drive with hardware encryption with a 10 foot pole. I’d rather purchase a Seagate drive.

Yes, certainly…but which current external seagate drive has RAID1? When I was checking the website there were none. Could you recommend any 2disk RAID1 enclosure from seagate within the price range of the My Book duo ?

notthesame

I’m very interested in one of these units, too. It may be too late to affect purchases already made, but I did a moderate comparison of the 2 different User Manuals, and the one for the MB Duo with encrypted drives (PDF file 4779-705120) has 103 pages in the PDF, while the User Manual for the MB Duo with unencrypted drives (PDF file 4779-705121) has only 94 pages in the PDF.

The manual for encrypted drives makes mention of 3 apps named:

  1. “WD Security or WD Drive Utilities software”,
  2. “WD Smartware software” and
  3. “WD Drive Unlock utility”

The only references to/use of the words “encrypt” or “encryption” I found in that manual were these:

  1. “This dual-drive device features blazing-fast transfer speeds, encrypted hardware RAID, and comprehensive local and cloud backup options.”
  2. “And with the 256-bit AES hardware encryption feature, you have peace of mind knowing that your files are secure.”
    both found on Page 6 of the PDF file within the Chapter titled “About Your WD Storage Device”.

I found no reference to/use of either the word “encrypt” or “encryption” in the manual for unencrypted drives, and it mentions only 2 named apps:

  1. “WD Smartware” and
  2. “WD Drive Utilities”

So, while it seems WD has provided a means to skirt mandatory encryption, they seem to have done so by removing the app/utility named “WD Security” and making encryption unavailable. It appears that while doing so, they have also removed the ability to “lock” the drives in the device. It appears neither the “encryption” nor the “lock” features are still available. (What I haven’t checked is if there has been a reduction in price upon removal of those features).

What remains unclear (at least to me) is which features one can expect to have available upon purchasing a new one of these devices. Is the User Manual for devices that support/allow encryption intended only for people who have already purchased one of these and those devices are no longer for sale, while the latest/current versions do not allow encryption? Or, are there 2 versions currently available for sale: one that allows encryption and one that does not?
If there are 2 versions of the device currently for sale, how can one be sure which version they’ll receive upon their purchase?

I’ve checked the web site of the vendor from whom I normally purchase hard drives, and the description there contains mention of encryption. Perhaps the vendor has not updated their web site, but it still makes me hesitant to purchase one of the devices.

I’ve bought nothing but WD hard drivers over the past 10 years, and am extremely disappointed that I’ve been unable to find any reference to or clear explanation of what WD has done to publicly address this dilemma. It would be most helpful and reassuring if I could find something issued from WD - preferably on their own web site - that clearly states: “The encryption feature for the WD My Book Duo is no longer included, regardless of what size storage capacity one purchases.”

Unfortunately for me, I couldn’t cancel my order from where I bought. Lucky for everyone else, I can share some real first hand user experience with the My Book duo.

Ok, here’s what I’ve found so far. Unfortunately WD does not allow posting the conversation I had with their support. And they have good reasons not to.

First things first.
If you expect to be able to take one of the disks out of the My Book duo plug it in a computer and read your data without any additional, time consuming recovery process, forget it !
This is assuming that you setup the My Book duo as RAID1(mirrored) and formatted in well known filesystem like NTFS, plug it directly into a standard computer and read your data. You will hit a roadblock. This is definitely not possible anymore.

The man from the support first said this was certainly possible, but he quickly had to admit, after letting me perform two different tests (one in a SATA enclosure, one directly internal in the computer), that it will not be possible to read my data, without using recovery software. The software is not provided by WD, and I would have to purchase it in addition to the drive.

Conclusion:
If you expect standard RAID1(mirrored) functionality, DON’T BUY the Western Digital My Book duo !
If you have already bought it: get rid of it, now ! If you don’t, you might deeply regret it later, when you find out for real that your, believed to be semi safe RAID1, was not safe at all from day one. (of course, archival and redundant backup strategies on other media should always prevent you from serious harm.)

(Please warn others about this. In online shops for example. It is dangerous how WD has implemented this functionality. I’m not even sure if their marketing would legally still hold up. I this still a RAID1 capable drive as advertised ? I highly doubt it)

This problem, does not necessarily need to be related to the encryption. It is just something the controller of the My Book duo does as the man from support stated.

So asking: “Does this drive always encrypt data ?”, will nowadays most likely lead to a “no” from WD. But that’s not the solution and definitive answer to this. The problem is, that the controller messes up standard drive access anyway, even without encryption.

For me there is no point right now in investigating further. I don’t want a RAID1(mirrored) drive, where my data needs to get processed by recovery software if the controller of the housing dies ! I’m not willing right now, to purchase recovery software in addition to the drive. Recovering data should be the very last step in preventing data loss. It can take ages for a 16TB (8TB in RAID1 mode) drive. And recovering data is not a 100% success in all cases, as far as my experience goes. Avoiding the need to perform data recovery is one of the main reasons to waste half of the space by switching to RAID1(mirrored).

According to the support, the manual which states “Unser manual (PDF)(unencrypted drives)” is there for Russia only. WD is not allowed to sell drives with encryption functionality, or the required software to Russia. They could make this much more clear on the homepage, or in the manuals for everyone to see.

Me too, I was quite happy with WD for many, many years. This changes things.
Unfortunately, the market for RAID1 capable drives isn’t huge. Or at least I haven’t found many alternatives right now. Most likely I will go with LaCie. It will be quite a bit more expensive, but anyway…knowing that my data is actually really safe and accessible on a RAID1 drive means more to me than money.

If someone has any suggestions, I’m looking forward to hear them. I need a drive with two internal disks which can be setup in RAID1. Connection wise it should have at least USB-3 or eSATA. Unfortunately I have no Thunderbolt on the box, where I want to plug this in.

Thank you !

Potentially similar problem.

8TB WD My Book Duo - RAID1 - Mac OSX 10.11 Sierra

Drive was working fine, no issues, sitting on a desk, no drops, spills, or other concerns. One day drive has just vanished from the operating system, unmounted, no longer visible.

Mac Disk Utility cannot see it but WD Drive Utilities can and lists it as “No Volumes Found”

Restart, reboot, unplug, pull out drives put them back in, tried a different but identical WD My Book Duo enclosure, tried a standard hard drive dock, tried both drives simultaneously, tried each drive individually, tried Disk Drill recovery software, NOTHING WORKS.

Is there really no way to recover my data off TWO separate drives simply because ONE enclosure appears to have failed?

If so, WD has some serious explaining to do

Yes, somehow that’s part of the problem. With RAID1 you would usually just plug one of the disks directly into a PC or Mac and read your data. Not with WD My Book duo RAID1, for this you need special recovery software.
The case you’re facing now, is exactly what I fear most. And thats the reason why I will have to get rid of my drive, before I have some important data on the drive and look for a better solution right now.

I only used recovery software once in my life. But thats 10 years + ago. Back then I used: http://www.r-studio.com/. And this software was actually quite good back then.

Before you start working on your drive make sure, you completely understand what you are doing with the software.
If you’re not an advanced user, it could also pay of to go to a company that offers data recovery services. But that will cost you usually quite some money. Maybe you can also contact WD support directly, and ask them about your best options to recover the data.

Warning: Do not perform a direct recovery attempt on the drive. Don’t modify the drive in any way. Before any recovery attempt you should use the recovery software to create a 1:1 sector copy of the drive onto some other drive with enough capacity. Once you have this copy, you can start working on this copy and try to get your data back. Don’t write to the original, now failed drive, don’t change anything on partitions etc… just read access for now.

1 Like

Ah sorry, just read it now, you have already tried recovering with DiskDrill recovery software.

I guess it won’t hurt to try different software. Some of them have a trial mode where you can test if the software would find and recognize your data. Like this you can test before buying.

WD Support recommended software from a company called “Wondershare”.

I hope you weren’t performing recovery, or any other attempts directly on the original disks. You should create a 1:1 copy to some image file first and work on this. Otherwise you might have, messed with the data even more, and this could make recovery impossible. That said, I have not played this through yet. Right now only WD support claimed that the data should be recoverable by standard recovery software. The same support also claimed first, that it should be possible to read the data directly. So, I’m not sure anymore what to believe, unless I have made my own tests.

That said, there are a lot of people writing on the internet about, that data is always encrypted on WD drives, even without a password set or any user interaction to explicitly enable encryption. Support said this wasn’t the case…but I really don’t know anymore how well they know their own product. (They also said, I could simply plug one of the drive to any computer and read the data right away…before I performed time consuming tests, proofed them wrong and they had to admit, that one would need recovery software to read from the drive)

For example there’s this project:
https://github.com/andlabs/reallymine

An entire project dealing with decryption of WD drives. The whole situation really seems totally messed up.

WD seems to have forgotten about their first and most important reason of existence: store data safely, so that the user will never loose any data and can have trust in his data storage solution. (something like this should be on their wall)

Most users should definitely be way more concerned about loosing data, than anyone spying on them. The average joe, does simply not have secrets that are important or matter to the world. With encryption, data loss is much more likely, it is therefore dangerous and should not be easily exposed to the average consumer.

I’ve done a bit more investigating and I think I have some additional info that may help.

Over the years I’ve purchased numerous (8+) My Book Duos, all RAID1, all without any issues, however all of them have been formatted as Mac OS Extended NOT ExFat.

For this drive in particular, I thought ExFat might be worth a shot since it’s supposedly cross compatible between Mac and PC.

It worked great for a month or so but then it seemingly vanished from the OS.

Just yesterday I had a new My Book Duo that I also formatted for ExFat. It was visible on the computer which had it mounted BUT it was not visible on the network to other computers.

This could be a total coincidence or it could be an issue with these drives formatting them for RAID1 ExFat and then using them on a Mac OS. Not sure if there’s any proof validating it one way or another but may be valuable for others to know and test.

If you are using a My Book Duo RAID 1 on a Mac, I would recommend staying away from ExFat for now just as a precaution.

Some further evidence:

I decided to cut my losses and reformat the drive (wasn’t much on the drive thankfully and hopefully after a reformat I could try and recover some lost files)

I reformatted as RAID1 HFS+J (instead of ExFat) and after a few errored attempts, what do you know, it’s mounted and back up and running!

Of course all the files are gone but it seems to be back in normal operating mode. I definitely can’t trust this drive anymore which is why it will be on its way back to Amazon but it does give me further evidence that it’s not a hardware problem with the enclosure or the drives, but rather with some software configuartion of RAID1 and ExFat.

Not definitive proof but more info for those that may stumble upon this post.

Further evidence:

After the HFS+J formating I pulled some disks from another My Book Duo RAID1 Array and put them in the suspect enclosure…

I can read the disk just fine, no issues whatsoever. So there doesn’t seem to be an issue with the enclosure or encryption or any kind of security protection.

I’m very convinced this was an issue with formating the RAID1 as ExFat. That seems to be the common denominator accounting for ALL my issues.

Thankfully this makes me feel a lot better knowing that ALL my My Book Duo RAID1s are readable by other enclosures and hard drive docks and can actually be used like proper RAID1’s.

As long as you avoid ExFat you should be okay. I also did some reading on this forum and it appears some people say to stay away from ExFat for RAIDs on Mac: https://forums.macrumors.com/threads/can-i-format-raid-1-drives-with-exfat.1363180/

1 Like