“Configure” Raid in “WD Drive Utilities” - How to recover data?

=> If someone speaks German, please see the problem description below in (better) German language … Thx.

A. History/Background

  1. This is a “MyBook Duo” = “My Cloud Home Duo” with the year of manufacture 2015 with USB 3.0 USB connection = a MyBook with DAS = Direct Attached Storage (so NOT a MyBook newer model, so NOT! a MyBook Cloud=NAS or similar);

  2. This MyBook duo was originally purchased with 2 x 6 TB Wesern Digital (WD) hard drives (HDDs) and configured with the windows program “WD Drive Utilities” as RAID-1 with ONE SINGLE large partition with name “data”;

  3. In the Windows “Disk Management” this MyBoo-Raid-1 was shown as ONE hard disk with - correctly - also only ONE partition with 5,589.00 GB as an error-free NTFS partition;

  4. Just because I heard that this MyBook Duo somehow works with encryption, I restarted the windows “WD Drive Utilities” program after about 4.5 years of use and looked for “Encryption”, “Password” or similar in the settings;

  5. Since I didn’t find anything, I clicked the “RAID Management” tab in the “WD Drive Utilities” application - because of a WRONG translation of WD !!! - on the “Configure” button, because I thought a new window with more settings would open;

    6.1. just write a NEW(!) Raid-1 over the already existing RAID-1
    6.2. and that (as I have found out by now) with the WD program “WD Quick Formater.exe”.

  7. But there was some kind of error with an error message (which I don’t remember);

  8. RESULT:
    8.1. The MyBook with the Raid-1 could no longer be accessed from Windows;
    8.2. In the Windows “Disk Management” only - correctly - ONE hard disk with 5,589.00 GB was displayed, but:
    => were now displayed with 2 partitions at once:
    8.2.1. FIRST partition with 2.048,00 GB WITHOUT a file system, but with the label “not assigned” and with
    8.2.2. SECOND partition with 3,541.00 GB also WITHOUT a file system, but also with the designation “not assigned”);
    8.3. In “WD Drive Utilities” under the tab “RAID Management” under Raid Status
    8.3.1. “Raid-1 (Mirror)” displayed;
    8.3.2. with “Raid status: low power.”
    8.3.3. (as well as “status drive 1: online” and “status drive 2: online”)

  9. So I MIRRORED these original 2 x HDDs one by one with the Linux program “dd” (“sudo dd if=/dev/sdf of=/dev/sdg bs=15M status=progress”) ONE BY ONE to 2 other (identical) WD-HDDs I had bought for this purpose and now I pushed these 2 (destination) HDDs into MyBook.
    9.1. (Of course) these HDDs could also not be accessed by Windows;
    9.2. Also in the Windows “Disk Management” (Note: Maybe the message: “Disk initialization” - I don’t know anymore) only - correctly - ONE hard disk with 5.589,00 GB was displayed, but
    => this HDD was now only with ONE partition with the size of 5,589.00 GB and the remark “Not allocated” or “Disk 1 unknown - not initialized”;
    9.3. In “WD Drive Utilities” these (target) HDDs were listed under the tab “RAID Management” under “Raid Status”
    9.3.1. “Raid-1 (Mirror)” displayed
    9.3.2. NOW BUT with the “Raid status: error-free”;
    9.3.3. (as well as “status drive 1: online” and “status drive 2: online”)

  10. When I tried to access the My Book with various recovery programs without success, I sent these 2 x HDDs with the MyBook to one of the data recovery companies recommended by WD.

B. Below are the problems that the data recovery company has:
=> The recovery company said that the HDDs themselves (!) are encrypted (i.e. INDEPENDENTLY/ ASIDE! to the hardware encryption of the MyBook);

  1. INFO about this from me No. 01: The access to all data was done by me but always WITHOUT entering a password by simply connecting the MyBook with the 2 HDDs to the computer via USB and using Win-Explorer to copy the data directly to the MyBook Raid1 hard drive connected via USB - An active (extra) password has not been used this side for years;

  2. INFO about this from me No. 02: But what can be is that I tried to set the password at the very beginning, but then deleted/reset the password again;

  3. INFO about this from me No. 03: What I can’t imagine either (but maybe it was done 4.5 years ago) is that I set a password and then clicked “Automatic Unlock” so that you don’t have to enter the password after every boot - as I said, I can’t imagine/remember that, especially since MyBook was connected to another computer without password request;

C. Does anyone have an idea?

D. “Ideas” from me:

  1. I think the key questions are,
    1.1. WHAT exactly happens when you click on the “Configure” button (see above)?
    1.2. WHAT does the “WD Quick Formater.exe” program do EXACTLY (until now I thought it was a quick formatting program);

  2. Somewhere in the Internet I read that WD or MyBook stores the RAID information (i.e. which raid) somewhere at the end of the hard disk(s)/HDDs - so I had the idea to create a raid-1 with the two newly purchased 2xWD-HDDs and then save these last sectors with Linux AND THEN “restore” these saved sectors to the ORIGINAL 2xHDDs, i.e. copy them to them. The only problem is, I do NOT know on which sectors the RAID information is stored - does anyone know?

  3. Why, according to the data recovery company, the HDDs (i.e. encryption also INTERNAL - i.e. encryption not only by hardware encryption) should be encrypted, I don’t understand.
    If I have been in front of about 4.5 years ago and clicked “Automatic Unlock”, someone knows where in Windows (or in which sectors on the HDD) WD-Utilities stores this “Automatic Unlock” information (according to my research, this password is stored directly on the MyBook in the firmware, i.e. somewhere on the hardware chip)? - Is there a way to access (read) this information? + Will this information be deleted when you click on the “Configure” button?

  4. Maybe WD Utilities has set a so-called “default” password for one of the steps just described? But with the passwords I found (123456 OR admin) it does not work according to the data recovery company.

F. Does anyone have any useful help and/or experience with this problem?
Thanks for help

#################### GERMAN: ####################

A. Vorgeschichte/Hintergrund

  1. Es geht hier um eine “MyBook Duo” = “My Cloud Home Duo” mit dem Herstellungsjahr 2015 mit USB 3.0-USB-Anschluss = eine MyBook mit DAS = Direct Attached Storage (also noch NICHT um eine MyBook neueren Modell, also NICHT! um eine MyBook Cloud=NAS o.ä.);

  2. Diese MyBook-Duo wurde original mit 2 x 6 TB Wesern Digital (WD) - Festplatten (HDDs) gekauft und mit dem Windows-Programm “WD Drive Utilities” als RAID-1 mit EINER EINZIGEN großen Partition “Daten” konfiguriert;

  3. In der Windows-“Datenträgerverwaltung” wurde dieses MyBoo-Raid-1 als EINE Festplatte mit - richtig - auch nur EINER Partition mit 5.589,00 GB als fehlerfreie NTFS-Partition angezeigt;

  4. Nur weil ich gehört habe, dass diese MyBook Duo irgendwie mit Verschlüsselung arbeitet, habe ich nach ca. 4,5 Jahren der Benutzung das Windows-Programm “WD Drive Utilities” erneut gestartet und nach “Verschlüsselung”, “Passwort” o.ä. in den Einstellungen gesucht;

  5. Da ich nichts gefunden hatte, klickte ich im Programm “WD Drive Utilities” in der Lasche “RAID-Verwaltung” - wegen einer FALSCHEN Übersetzung von WD !!! - auf den Knopf “Konfigurieren”, weil ich dachte, dass dann ein neues Fenster mit weiteren Einstellungen aufgeht;

  6. STATTDESSEN wurde aber:
    6.1. über das bereits bestehende RAID-1 einfach ein NEUES(!) Raid-1 darüber geschrieben
    6.2. und zwar (wie ich mittlerweile herausgefunden habe) mit dem WD-Programm “WD Quick Formater.exe”.

  7. Allerdings trat hierbei irgendein Fehler mit einer Fehleranzeige auf (an die ich mich aber nicht mehr erinnere);

    8.1. Auf die MyBook mit dem Raid-1 konnte von Windows aus nicht mehr zugegriffen werden;
    8.2. In der Windows-“Datenträgerverwaltung” wurde jetzt zwar auch nur - richtig - EINE Festplatte mit 5.589,00 GB angezeigt, allerdings:
    => wurden jetzt auf einmal mit 2 Partitionen angezeigt:
    8.2.1. ERSTE Partition mit 2.048,00 GB OHNE ein Dateisystem, sondern mit der Bezeichnung “nicht zugeordnet” und mit
    8.2.2. ZWEITE Partition mit 3.541,00 GB ebenfalls OHNE ein Dateisystem, sondern auch mit der Bezeichnung “nicht zugeordnet”);
    8.3. In “WD Drive Utilities” wurde unter der Lasche “RAID-Verwaltung” unter Raid-Status
    8.3.1. “Raid-1 (Mirror)” angezeigt;
    8.3.2. mit dem “Raid-Status: leistungsschwach”;
    8.3.3. (sowie “Status Laufwerk 1: Online” und “Status Laufwerk 2: Online”)

  9. Ich SPIEGELTE daher diese originalen 2 x HDDs einzeln mit dem Linux-Programm “dd” (“sudo dd if=/dev/sdf of=/dev/sdg bs=15M status=progress”) JEWEILS einzeln auf 2 andere (identische) WD-HDDs, die ich dafür extra gekauft hatte und schob nun DIESE 2 (Ziel-)HDDs in die MyBook.
    9.1. (Natürlich) konnte auch auf diese Festplatten nicht von Windows zugegriffen werden;
    9.2. Auch in der Windows-“Datenträgerverwaltung” wurde jetzt (Anmerkung: Vielleicht kam auch vorher noch die Meldung: “Datenträgerinitialisierung” - ich weiß es nicht mehr) zwar auch nur - richtig - EINE Festplatte mit 5.589,00 GB angezeigt, allerdings
    => wurde diese HDD jetzt nur mit EINER Partition mit der Größe von 5.589,00 GB und der Bemerkung “Nicht zugeordnet” bzw. “Datenträger 1 unbekannt - nicht initialisiert”;
    9.3. In “WD Drive Utilities” wurde bei diesen (Ziel)-HDDS unter der Lasche “RAID-Verwaltung” unter “Raid-Status”
    9.3.1. “Raid-1 (Mirror)” angezeigt
    9.3.2. JETZT ABER mit dem “Raid-Status: fehlerfrei”;
    9.3.3. (sowie “Status Laufwerk 1: Online” und “Status Laufwerk 2: Online”)

  10. Als ich dann ohne Erfolg mit diversen Wiederherstellungsprogrammen versucht hatte, auf die My Book zuzugreifen, habe ich diese 2 x HDDs mit der MyBook zu einer der von WD empfohlenen Datenwiederherstellungsfirma geschickt.

B. Nachfolgend jetzt die Probleme, die die Datenwiederherstellungsfirma hat:
=> Die Wiederherstellungsfirma teilte mit, dass die HDDs selsber verschlüsselt seien (also UNABHÄNGIG/NEBEN! der Hardware-Veschlüsselung der MyBook);

  1. INFO dazu von mir Nr. 01: Der Zugriff auf alle Daten erfolgte von mir aber immer OHNE Passwort-Eingabe dadurch, dass die MyBook mit den 2 HDDs einfach per USB am Rechner angeschlossen wurde und mit dem Win-Explorer die Daten direkt auf die per USB angeschlossene MyBook-Raid1-Festplatte kopiert wurden - Ein aktives (Extra-)Passwort wurde diesseits seit Jahren nicht mehr verwendet;

  2. INFO dazu von mir Nr. 02: Was sein kann ist aber, dass ich ganz am Anfang das Passwortsetzen ausprobiert, dann aber das Passwort wieder gelöscht/zurückgesetzt habe;

  3. INFO dazu von mir Nr. 03: Was ich mir auch nicht vorstellen kann ist (aber vielleicht doch vor 4,5 Jahren gemacht wurde), dass ich ein Passwort gesetzt hatte und dann auf “Automatisches Entsperren” geklickt habe, damit man nicht nach jedem Booten das Passwort eingeben muss- wie gesagt, kann ich mir nicht vorstellen/erinnern, zumal die MyBook meiner Erinnerung nach auch einmal an einen anderen Rechner ohne Passwort-Abfrage angeschlossen wurde;

C. Hat jemand eine Idee?

D. “Ideen” von mir:

  1. Die wesentliche Fragen dürften sein,
    1.1. WAS passiert beim Klicken auf den Knopf “Konfigurieren” (s.o.) GENAU?;
    1.2. WAS macht das Programm “WD Quick Formater.exe” GENAU (bisher dachte ich, eine Schnellformatierung);

  2. Irgendwo habe ich im Internet gelesen, dass WD bzw. die MyBook die RAID-Informationen (also welches Raid) irgendwo am Ende Festplatte(n)/HDDs abspeichert - so dass ich die Idee hatte, mit den zwei neu gekauften 2xWD-HDDs ein Raid-1 anzulegen und dann mit Linux DIESE letzten Sektoren abzuspeichern UND DANN diese abgespeicherten Sektoren auf die URSPRÜNGLICHEN 2xHDDs “wiederherzustellen”, d.h. darauf zu kopieren. Problem ist nur, ich weiß NICHT, auf welchen Sektoren die RAID-Informationen gespeichert werden - weiß das jemand?;

  3. Wieso laut der Datenwiederherstellungsfirma die HDDs (also auch die Verschlüsselung INTERN - d.h. nicht nur durch die Hardware-Verschlüsselung) verschlüsselt sein sollen, verstehe ich nicht.
    Falls ich vor ca. 4,5 Jahren ein Passwort gesetzt haben sollte und “Automatisches Entsperren” angeklickt haben sollte, weiß jemand, wo in Windows (oder in welchen Sektoren auf der HDD) WD-Utilities diese “Automatisches Entsperren”-Informationen abspeichert werden (nach meinen Recherchen wird dieses Passwort direkt auf der MyBook in der Firmware abgespeichert, also irgendwo auf dem Hardware-Chip)? - Gibt es eine Möglichkeit hierauf (lesend) zuzugreifen? + Werden diese Informationen vielleicht gelöscht, wenn man auf den Knopf “Konfigurieren” klickt?

  4. Vielleicht hat WD Utilities auch bei einen der soeben beschriebenen Schritte eine sogenanntes „Standard“-Passwort gesetzt? Mit den Passwörtern, die ich gefunden habe (123456 ODER admin) funktioniert es laut der Datenwiederherstellungsfirma aber nicht.

F. Hat jemand eine sinnvolle Hilfe und/oder Erfahrung mit diesem Problem?
Danke für Hilfe