WD My Book 2TB stopped working AFTER 2 MONTHS

System: intel i5 2500k on gigabyte z68 ud3h board running win 7 pro 64-bit.  

HD worked perfectly fine out of the box so I transferred all of my data onto the external so I could format my drives for a new build.  The HD was recognized fine by the new pc, and fine by my blu-ray player.  After 2 freakin months the HD isn’t recognized by anything, not by the PC nor the bluray player, and I get the infamous “click of death” when booting up, 3-4 clicks/flashing then solid light and nothing is read.  Furthermore when I try to power it off now with a long press, it doesn’t power off, it just goes into a (standby?) mode where the light blinks on and off in even intervals.  Drive doesn’t show up in disk management and isn’t recognized by bluray player anymore when on either. 

Is there any reasonable solution to this problem?  Or did I just spend $100 on something that not only failed after 2 months, but effectively deleted the last 6 years of my life.  Either way this product really screwed me over and it pains me to see so many people on other forums suffering from the same problem with no way to fix it.  Wish I had heard about the “click of death” phenomena before purchasing this thing.  Solid hardware build WD, and thanks for making me want to smash something as I watch 6 years of data vanish. 

Have you tried the obvious things like trying a different USB ports and cable? Or ty moving the power supply to a different receptacle not in a surge protector? Sadly these forums are full of people who trusted important data to just one ddrive and had problems. One copy is not a backup.