WD Media Player stopped playing films

Hello everyone

Never had a problem with my little black box, so this is my first time on the website :wink:

ok i have the media player with No hard drive…print is so small i think this is the model number…



Problem - ok it finds the files / films on the Portable External Hard Drive then when you select the file the player bar apears on the bottom, screen goes black, but film does not play…

Portable External Hard Drive

tested on my pc all files play, also tested for errors, h-drive is 100% fine

Update info even the avi files not playing

You have WD TV HD Media Player (Gen 1) my favorite

Forum for it is in archives :slight_smile:


Just reset it. You can do hard reset buy pushing button, just use toothpick, hardreset buton is in little hole next to USB port on the side.

Also you could check iof you are running last firmware 1.03

if you don´t, download it from here


Just tried it, sadly No joy ! but also noticed the USB light flashing like crazy !

i will be back later tonight with some more info, as my sister as the same set up. i am going to try it there with, swapping gear around…

but thanks for your replie

bit more info it does not play off a USB Stick as well, just tried, but this time the usb light does not flicker !

i think its broken…any updates for it ?

Usually when USB light flickers it means it is working. Maybe it´s scaning media?

Try this: conect your USB drive to PC and do Error-check?

mmm tried that. what i have found out it play all whats on the drive when you select play ALL

but if you select the folder opition it does not, maybe a update is needed ?

still as the old one think or something like that…

I remmeber having same problem, usually it was just one crapy video that would cause it or some system error on disc.

Try updating firmware